summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/rtl22xx/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:49:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:49:27 +0000
commit06ec9001b84b07397331ac2ccbcc4d977231524f (patch)
treefa65ce43afe93e7f240467ea0bd56de1ede60960 /c/src/lib/libbsp/arm/rtl22xx/Makefile.am
parent2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-06ec9001b84b07397331ac2ccbcc4d977231524f.tar.bz2
2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, console/uart.c, startup/bspstart.c: Use standardized bsp_cleanup() which can optionally print a message, poll for user to press key, and call bsp_reset(). Using this eliminates the various bsp_cleanup() implementations which had their own implementation and variety of string constants. * startup/bspclean.c: Removed.
Diffstat (limited to 'c/src/lib/libbsp/arm/rtl22xx/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/rtl22xx/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/arm/rtl22xx/Makefile.am b/c/src/lib/libbsp/arm/rtl22xx/Makefile.am
index d8c85eb4c7..d01eb4cb37 100644
--- a/c/src/lib/libbsp/arm/rtl22xx/Makefile.am
+++ b/c/src/lib/libbsp/arm/rtl22xx/Makefile.am
@@ -29,7 +29,8 @@ dist_project_lib_DATA += startup/linkcmds
include_HEADERS += ../../arm/shared/comm/uart.h
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
- ../../shared/bspgetworkarea.c startup/bspstart.c startup/bspclean.c \
+ ../../shared/bspgetworkarea.c startup/bspstart.c \
+ ../../shared/bspclean.c startup/bspreset.c \
../../shared/bootcard.c ../../shared/sbrk.c \
../../shared/gnatinstallhandler.c
console_SOURCES = ../../shared/console.c