summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
diff options
context:
space:
mode:
authorPavel Pisa <pisa@cmp.felk.cvut.cz>2016-09-07 20:28:33 +0200
committerPavel Pisa <pisa@cmp.felk.cvut.cz>2016-09-07 20:29:39 +0200
commitdf2ee9d37717cdf2add689292415fe14bf9986ae (patch)
treee3c11683483a247eae71c664c8e91eee8ae66c3b /c/src/lib/libbsp/arm/raspberrypi/Makefile.am
parentarm/raspberrypi: propagate number of configured CPUs into linker script. (diff)
downloadrtems-df2ee9d37717cdf2add689292415fe14bf9986ae.tar.bz2
arm/raspberrypi: basic BCM2836 SMP implementation.
The BSP support is divided to startup/bspsmp_api.c file where functions required by SuperCore are defined and BCM2836 hardware initialization part in startup/bspsmp_init.c. Separation is done to prevent smpfatal08 test build failure.
Diffstat (limited to 'c/src/lib/libbsp/arm/raspberrypi/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/raspberrypi/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/raspberrypi/Makefile.am b/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
index 01f4ad226d..dfcc3e5db3 100644
--- a/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
+++ b/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
@@ -100,6 +100,10 @@ libbsp_a_SOURCES += ../../shared/bspreset_loop.c
libbsp_a_SOURCES += startup/bspstart.c
libbsp_a_SOURCES += startup/cmdline.c
libbsp_a_SOURCES += startup/bspgetworkarea.c
+if HAS_SMP
+libbsp_a_SOURCES += startup/bspsmp_api.c
+libbsp_a_SOURCES += startup/bspsmp_init.c
+endif
# IRQ
libbsp_a_SOURCES += ../shared/arm-cp15-set-exception-handler.c