summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
diff options
context:
space:
mode:
authorAndre Marques <andre.lousa.marques@gmail.com>2015-07-27 17:01:44 +0100
committerGedare Bloom <gedare@rtems.org>2015-08-06 10:53:46 -0400
commit61e7c698a44137afbc1447ed328b14a0d9e55016 (patch)
treed253c7a028c02c17089283eab1078b8533fde4b8 /c/src/lib/libbsp/arm/raspberrypi/Makefile.am
parentRTEMS GPIO API definition and implementation. (diff)
downloadrtems-61e7c698a44137afbc1447ed328b14a0d9e55016.tar.bz2
Raspberry Pi implementation for the RTEMS GPIO API.
Added support for the new RTEMS GPIO API functions. Test cases can be found in https://github.com/asuol/RTEMS_rpi_testing/tree/master/GPIO
Diffstat (limited to 'c/src/lib/libbsp/arm/raspberrypi/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/raspberrypi/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/raspberrypi/Makefile.am b/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
index c6133df707..03be7119c0 100644
--- a/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
+++ b/c/src/lib/libbsp/arm/raspberrypi/Makefile.am
@@ -44,6 +44,7 @@ include_bsp_HEADERS += include/irq.h
include_bsp_HEADERS += include/mmu.h
include_bsp_HEADERS += include/usart.h
include_bsp_HEADERS += include/raspberrypi.h
+include_bsp_HEADERS += include/rpi-gpio.h
include_libcpu_HEADERS = ../../../libcpu/arm/shared/include/cache_.h \
../../../libcpu/arm/shared/include/arm-cp15.h
@@ -86,6 +87,7 @@ libbsp_a_SOURCES += ../../shared/cpucounterdiff.c
libbsp_a_SOURCES += ../../shared/gnatinstallhandler.c
libbsp_a_SOURCES += ../../shared/sbrk.c
libbsp_a_SOURCES += ../../shared/src/stackalloc.c
+libbsp_a_SOURCES += ../../shared/gpio.c
libbsp_a_SOURCES += ../shared/startup/bsp-start-memcpy.S
libbsp_a_SOURCES += ../shared/arm-cp15-set-ttb-entries.c
@@ -117,6 +119,9 @@ libbsp_a_SOURCES += clock/clockdrv.c ../../../shared/clockdrv_shell.h
# Timer
libbsp_a_SOURCES += misc/timer.c
+# GPIO
+libbsp_a_SOURCES += gpio/rpi-gpio.c
+
# RTC
# SSP