summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/armulator/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 20:07:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 20:07:01 +0000
commite86adc797d291ed76c3d9699509f1ad6ac231e76 (patch)
tree1893223eb83735ff27f9fa68fde36a3b0c4a9b1a /c/src/lib/libbsp/arm/armulator/include/Makefile.am
parent2001-05-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e86adc797d291ed76c3d9699509f1ad6ac231e76.tar.bz2
2001-05-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add include/bspopts.h. * console/Makefile.am: Use *_HEADERS instead of *H_FILES. * irq/Makefile.am: Use *_HEADER instead of *H_FILES. * include/.cvsignore: Add bspopts.h*, coverhd.h, stamp-h* * include/Makefile.am: Add bspopts.h, Use *_HEADER instead of *H_FILES. * include/bsp.h: Add bspopts.h.
Diffstat (limited to 'c/src/lib/libbsp/arm/armulator/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/armulator/include/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/arm/armulator/include/Makefile.am b/c/src/lib/libbsp/arm/armulator/include/Makefile.am
index 534884ac59..b11145642e 100644
--- a/c/src/lib/libbsp/arm/armulator/include/Makefile.am
+++ b/c/src/lib/libbsp/arm/armulator/include/Makefile.am
@@ -4,7 +4,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = bsp.h ../../../shared/include/coverhd.h
+include_HEADERS = bsp.h coverhd.h bspopts.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -12,14 +12,12 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
- $(INSTALL_DATA) $< $@
+coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ cp $< $@
+CLEANFILES += coverhd.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
- $(PROJECT_INCLUDE)/coverhd.h
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = bsp.h
-
include $(top_srcdir)/../../../../../../automake/local.am