summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/armulator/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-06-12 19:46:53 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-06-12 19:46:53 +0000
commit85591ad7b2141a4c5707ab2281c94dc2a563a14d (patch)
tree1c0dd1f38ddb873c74a65400a2d37c15ce4c8877 /c/src/lib/libbsp/arm/armulator/Makefile.am
parent2007-06-12 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-85591ad7b2141a4c5707ab2281c94dc2a563a14d.tar.bz2
2007-06-12 Joel Sherrill <joel.sherrill@OARcorp.com>
* armulator/.cvsignore, armulator/ChangeLog, armulator/Makefile.am, armulator/bsp_specs, armulator/configure.ac, armulator/preinstall.am, armulator/clock/clockdrv.c, armulator/console/console-io.c, armulator/console/mon-syscalls.S, armulator/include/.cvsignore, armulator/include/bsp.h, armulator/include/tm27.h, armulator/start/start.S, armulator/startup/bspstart.c, armulator/startup/libcfunc.c, armulator/startup/linkcmds, armulator/startup/swi.h, armulator/startup/syscalls.c, armulator/startup/trap.S: Removed.
Diffstat (limited to 'c/src/lib/libbsp/arm/armulator/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/armulator/Makefile.am61
1 files changed, 0 insertions, 61 deletions
diff --git a/c/src/lib/libbsp/arm/armulator/Makefile.am b/c/src/lib/libbsp/arm/armulator/Makefile.am
deleted file mode 100644
index 22ed4f82ce..0000000000
--- a/c/src/lib/libbsp/arm/armulator/Makefile.am
+++ /dev/null
@@ -1,61 +0,0 @@
-##
-## $Id$
-##
-
-ACLOCAL_AMFLAGS = -I ../../../../aclocal
-
-noinst_PROGRAMS =
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
-
-dist_project_lib_DATA = bsp_specs
-
-include_HEADERS = include/bsp.h
-include_HEADERS += include/tm27.h
-
-nodist_include_HEADERS = include/bspopts.h
-DISTCLEANFILES = include/bspopts.h
-nodist_include_HEADERS += ../../shared/include/coverhd.h
-
-EXTRA_DIST = start/start.S
-start.$(OBJEXT): start/start.S
- $(CPPASCOMPILE) -o $@ -c $<
-project_lib_DATA = start.$(OBJEXT)
-
-dist_project_lib_DATA += startup/linkcmds
-
-noinst_PROGRAMS += startup.rel
-startup_rel_SOURCES = startup/trap.S ../../shared/bsplibc.c \
- ../../shared/bsppost.c startup/bspstart.c ../../shared/bootcard.c \
- ../../shared/sbrk.c \
- ../../shared/gnatinstallhandler.c startup/libcfunc.c startup/syscalls.c
-startup_rel_CPPFLAGS = $(AM_CPPFLAGS)
-startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += clock.rel
-clock_rel_SOURCES = clock/clockdrv.c
-clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += console.rel
-console_rel_SOURCES = console/console-io.c ../../shared/console-polled.c
-console_rel_CPPFLAGS = $(AM_CPPFLAGS)
-console_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += timer.rel
-timer_rel_SOURCES = ../../shared/timerstub.c
-timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += abort.rel
-abort_rel_SOURCES = ../shared/abort/abort.c
-abort_rel_CPPFLAGS = $(AM_CPPFLAGS)
-abort_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_LIBRARIES = libbsp.a
-libbsp_a_SOURCES =
-libbsp_a_LIBADD = startup.rel clock.rel console.rel timer.rel abort.rel
-
-include $(srcdir)/preinstall.am
-include $(top_srcdir)/../../../../automake/local.am