summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-27 06:17:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-27 06:17:44 +0000
commit2d354ea6a562761a1417bed71dfe8e722ef16409 (patch)
tree85f2250aac8208be0365caae8e27cfc583fa67ca /c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am
parentPort of RTEMS to the ARM processor family by Eric Valette (diff)
downloadrtems-2d354ea6a562761a1417bed71dfe8e722ef16409.tar.bz2
Minor problems addressed with the merger and with the arm_bare_bsp.
That BSP now has a stub clock driver so the tests can link even if they won't execute. A handful of Makefiles had to be updated and we had to account for printk.c being a shared file now.
Diffstat (limited to 'c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am b/c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am
new file mode 100644
index 0000000000..7c33173275
--- /dev/null
+++ b/c/src/lib/libbsp/arm/arm_bare_bsp/clock/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/clock.rel
+
+C_FILES = clockdrv.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = ckinit.c
+
+include $(top_srcdir)/../../../../../../automake/local.am