summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-03 05:16:57 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-03 05:16:57 +0000
commit7f0e84c5fad5cb757647ec6d94cbff3aedfb88bb (patch)
tree5bd54ab47abfffcbf28d02094a27a899eeda0e0d /c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am
parent2003-12-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7f0e84c5fad5cb757647ec6d94cbff3aedfb88bb.tar.bz2
2003-12-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add preinstallation dirstamp support. * clock/Makefile.am: Cosmetics. * console/Makefile.am: Cosmetics. * irq/Makefile.am: Add preinstallation dirstamp support. * startup/Makefile.am: Cosmetics. * timer/Makefile.am: Cosmetics.
Diffstat (limited to 'c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am b/c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am
index 67cd1314d2..9c02c90027 100644
--- a/c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am
+++ b/c/src/lib/libbsp/arm/arm_bare_bsp/Makefile.am
@@ -16,12 +16,12 @@ nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
all-local: $(PREINSTALL_FILES)
-$(PROJECT_INCLUDE)/registers.h: include/registers.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/registers.h: include/registers.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/registers.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/registers.h
-$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am