summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
diff options
context:
space:
mode:
authorRalf Kirchner <ralf.kirchner@embedded-brains.de>2013-07-31 09:45:59 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-13 16:22:00 +0100
commitf73cfe99d099e600be3205efae7980e426ad9ea0 (patch)
treec000783a4c6eec14f9ecd7b5fbaf9c34fe9bfbed /c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
parentlibchip: Add dwmac 10/100/1000 network driver (diff)
downloadrtems-f73cfe99d099e600be3205efae7980e426ad9ea0.tar.bz2
bsp/altera-cyclone-v: New BSP
Implemented so far: - nocache heap for uncached RAM - basic timer - level 1 cache handling for arm cache controller in arm-cache-l1.h - level 2 L2C-310 cache controller - MMU - DWMAC 1000 ethernet controller - basic errata handling - smp startup for second core
Diffstat (limited to 'c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am197
1 files changed, 197 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am b/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
new file mode 100644
index 0000000000..64703a2996
--- /dev/null
+++ b/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
@@ -0,0 +1,197 @@
+##
+#
+# @file
+#
+# @brief Makefile of LibBSP for the Altera Cyclone-V platform.
+#
+
+ACLOCAL_AMFLAGS = -I ../../../../aclocal
+
+include $(top_srcdir)/../../../../automake/compile.am
+
+include_bspdir = $(includedir)/bsp
+include_libcpudir = $(includedir)/libcpu
+
+dist_project_lib_DATA = bsp_specs
+
+###############################################################################
+# Header #
+###############################################################################
+
+include_HEADERS = include/bsp.h
+include_HEADERS += include/tm27.h
+
+nodist_include_HEADERS = ../../shared/include/coverhd.h \
+ include/bspopts.h
+
+nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
+
+include_bsp_HEADERS =
+include_bsp_HEADERS += ../../shared/include/utility.h
+include_bsp_HEADERS += ../../shared/include/irq-generic.h
+include_bsp_HEADERS += ../../shared/include/irq-info.h
+include_bsp_HEADERS += ../../shared/include/stackalloc.h
+include_bsp_HEADERS += ../../shared/tod.h
+include_bsp_HEADERS += ../shared/include/start.h
+include_bsp_HEADERS += ../shared/include/arm-a9mpcore-clock.h
+include_bsp_HEADERS += ../shared/include/arm-a9mpcore-irq.h
+include_bsp_HEADERS += ../shared/include/arm-a9mpcore-regs.h
+include_bsp_HEADERS += ../shared/include/arm-a9mpcore-start.h
+include_bsp_HEADERS += ../shared/include/arm-cp15-start.h
+include_bsp_HEADERS += ../shared/include/arm-errata.h
+include_bsp_HEADERS += ../shared/include/arm-gic.h
+include_bsp_HEADERS += ../shared/include/arm-gic-irq.h
+include_bsp_HEADERS += ../shared/include/arm-gic-regs.h
+include_bsp_HEADERS += ../shared/include/arm-gic-tm27.h
+include_bsp_HEADERS += ../shared/include/arm-release-id.h
+include_bsp_HEADERS += include/irq.h
+include_bsp_HEADERS += include/nocache-heap.h
+
+# Altera hwlib
+include_bsp_HEADERS += hwlib/include/alt_address_space.h
+include_bsp_HEADERS += hwlib/include/alt_clock_group.h
+include_bsp_HEADERS += hwlib/include/alt_clock_manager.h
+include_bsp_HEADERS += hwlib/include/alt_generalpurpose_io.h
+include_bsp_HEADERS += hwlib/include/alt_hwlibs_ver.h
+include_bsp_HEADERS += hwlib/include/alt_interrupt_common.h
+include_bsp_HEADERS += hwlib/include/alt_mpu_registers.h
+include_bsp_HEADERS += hwlib/include/alt_reset_manager.h
+include_bsp_HEADERS += hwlib/include/hwlib.h
+#The following Altera hwlib header files have been left out because so far
+#they are not required:
+#include_bsp_HEADERS += hwlib/include/alt_16550_uart.h
+#include_bsp_HEADERS += hwlib/include/alt_bridge_manager.h
+#include_bsp_HEADERS += hwlib/include/alt_dma_common.h
+#include_bsp_HEADERS += hwlib/include/alt_dma_program.h
+#include_bsp_HEADERS += hwlib/include/alt_dma.h
+#include_bsp_HEADERS += hwlib/include/alt_fpga_manager.h
+#include_bsp_HEADERS += hwlib/include/alt_globaltmr.h
+#include_bsp_HEADERS += hwlib/include/alt_system_manager.h
+#include_bsp_HEADERS += hwlib/include/alt_timers.h
+#include_bsp_HEADERS += hwlib/include/alt_watchdog.h
+#The following Altera hwlib headers would be problematic with RTEMS:
+#include_bsp_HEADERS += hwlib/include/alt_interrupt.h
+#All header files from hwlib/include/socal are regarded as BSP
+#internal and thus not installed
+
+include_libcpu_HEADERS = ../../../libcpu/arm/shared/include/arm-cp15.h
+
+
+
+###############################################################################
+# Data #
+###############################################################################
+
+noinst_LIBRARIES = libbspstart.a
+
+libbspstart_a_SOURCES = ../shared/start/start.S
+
+project_lib_DATA = start.$(OBJEXT)
+
+project_lib_DATA += startup/linkcmds
+project_lib_DATA += startup/linkcmds.altcycv
+project_lib_DATA += startup/linkcmds.altcycv_devkit
+project_lib_DATA += startup/linkcmds.altcycv_devkit_smp
+
+###############################################################################
+# LibBSP #
+###############################################################################
+
+noinst_LIBRARIES += libbsp.a
+
+libbsp_a_SOURCES =
+libbsp_a_CPPFLAGS =
+libbsp_a_LIBADD =
+
+# for the Altera hwlib
+libbsp_a_CPPFLAGS += -I ${srcdir}/hwlib/include
+libbsp_a_CPPFLAGS += -std=gnu99
+
+# hwlib from Altera
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_address_space.c
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_clock_manager.c
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_generalpurpose_io.c
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_reset_manager.c
+#The following Altera hwlib source files have been left out because so far
+#they are not required:
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_16550_uart.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_bridge_manager.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_dma_program.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_dma.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_fpga_manager.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_globaltmr.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_system_manager.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_timers.c
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_watchdog.c
+# The following Altera hwlib source files would be problematic with RTEMS:
+#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_interrupt.c
+
+
+# Shared
+libbsp_a_SOURCES += ../../shared/bootcard.c
+libbsp_a_SOURCES += ../../shared/bspclean.c
+libbsp_a_SOURCES += ../../shared/bspgetworkarea.c
+libbsp_a_SOURCES += ../../shared/bsplibc.c
+libbsp_a_SOURCES += ../../shared/bsppost.c
+libbsp_a_SOURCES += ../../shared/bsppredriverhook.c
+libbsp_a_SOURCES += ../../shared/bsppretaskinghook.c
+libbsp_a_SOURCES += ../../shared/cpucounterdiff.c
+libbsp_a_SOURCES += ../../shared/gnatinstallhandler.c
+libbsp_a_SOURCES += ../../shared/sbrk.c
+libbsp_a_SOURCES += ../../shared/timerstub.c
+libbsp_a_SOURCES += ../../shared/src/stackalloc.c
+libbsp_a_SOURCES += ../shared/abort/simple_abort.c
+libbsp_a_SOURCES += ../shared/startup/bsp-start-memcpy.S
+libbsp_a_SOURCES += ../shared/arm-cp15-set-exception-handler.c
+libbsp_a_SOURCES += ../shared/arm-cp15-set-ttb-entries.c
+
+# Startup
+libbsp_a_SOURCES += startup/bspreset.c
+libbsp_a_SOURCES += startup/bspstart.c
+libbsp_a_SOURCES += startup/nocache-heap.c
+
+# IRQ
+libbsp_a_SOURCES += ../../shared/src/irq-default-handler.c
+libbsp_a_SOURCES += ../../shared/src/irq-generic.c
+libbsp_a_SOURCES += ../../shared/src/irq-info.c
+libbsp_a_SOURCES += ../../shared/src/irq-legacy.c
+libbsp_a_SOURCES += ../../shared/src/irq-server.c
+libbsp_a_SOURCES += ../../shared/src/irq-shell.c
+libbsp_a_SOURCES += ../shared/arm-gic-irq.c
+
+# Network
+libbsp_a_SOURCES += network/network.c
+
+# Console
+libbsp_a_SOURCES += ../../shared/console.c
+libbsp_a_SOURCES += ../../shared/console_control.c
+libbsp_a_SOURCES += ../../shared/console_read.c
+libbsp_a_SOURCES += ../../shared/console_select_simple.c
+libbsp_a_SOURCES += ../../shared/console_write.c
+libbsp_a_SOURCES += console/console-config.c
+
+# Clock
+libbsp_a_SOURCES += ../../shared/clockdrv_shell.h
+libbsp_a_SOURCES += ../shared/arm-a9mpcore-clock-config.c
+
+# Cache
+libbsp_a_SOURCES += ../../../libcpu/shared/src/cache_manager.c
+libbsp_a_SOURCES += ../shared/include/arm-cache-l1.h
+libbsp_a_SOURCES += ../shared/arm-l2c-310/cache_.h
+libbsp_a_CPPFLAGS += -I$(srcdir)/../shared/arm-l2c-310
+
+# Start hooks
+libbsp_a_SOURCES += startup/bspstarthooks.c
+
+if HAS_SMP
+libbsp_a_SOURCES += ../shared/arm-a9mpcore-smp.c
+endif
+
+###############################################################################
+# Special Rules #
+###############################################################################
+
+DISTCLEANFILES = include/bspopts.h
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/../../../../automake/local.am