summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-08-26 16:00:44 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-08-26 17:10:18 +0200
commit76386c1047ea15a05965adcab371bba2147831ba (patch)
tree08c96905a4733b0ea4a0ef96b7028c4370b437ff /c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
parentbsp/altera-cyclone-v: Update to hwlib 13.1 (diff)
downloadrtems-76386c1047ea15a05965adcab371bba2147831ba.tar.bz2
bsp/altera-cyclone-v: Add DMA support hwlib files
Diffstat (limited to 'c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am21
1 files changed, 14 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am b/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
index a581dee90d..aad1db10c3 100644
--- a/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
+++ b/c/src/lib/libbsp/arm/altera-cyclone-v/Makefile.am
@@ -51,23 +51,25 @@ include_bsp_HEADERS += include/irq.h
include_bsp_HEADERS += include/nocache-heap.h
# Altera hwlib
+include_bsp_HEADERS += hwlib/include/alt_16550_uart.h
include_bsp_HEADERS += hwlib/include/alt_address_space.h
+include_bsp_HEADERS += hwlib/include/alt_cache.h
include_bsp_HEADERS += hwlib/include/alt_clock_group.h
include_bsp_HEADERS += hwlib/include/alt_clock_manager.h
+include_bsp_HEADERS += hwlib/include/alt_dma_common.h
+include_bsp_HEADERS += hwlib/include/alt_dma.h
+include_bsp_HEADERS += hwlib/include/alt_dma_program.h
include_bsp_HEADERS += hwlib/include/alt_generalpurpose_io.h
include_bsp_HEADERS += hwlib/include/alt_hwlibs_ver.h
include_bsp_HEADERS += hwlib/include/alt_i2c.h
include_bsp_HEADERS += hwlib/include/alt_interrupt_common.h
include_bsp_HEADERS += hwlib/include/alt_mpu_registers.h
+include_bsp_HEADERS += hwlib/include/alt_qspi_private.h
include_bsp_HEADERS += hwlib/include/alt_reset_manager.h
include_bsp_HEADERS += hwlib/include/hwlib.h
#The following Altera hwlib header files have been left out because so far
#they are not required:
-#include_bsp_HEADERS += hwlib/include/alt_16550_uart.h
#include_bsp_HEADERS += hwlib/include/alt_bridge_manager.h
-#include_bsp_HEADERS += hwlib/include/alt_dma_common.h
-#include_bsp_HEADERS += hwlib/include/alt_dma_program.h
-#include_bsp_HEADERS += hwlib/include/alt_dma.h
#include_bsp_HEADERS += hwlib/include/alt_fpga_manager.h
#include_bsp_HEADERS += hwlib/include/alt_globaltmr.h
#include_bsp_HEADERS += hwlib/include/alt_system_manager.h
@@ -79,9 +81,13 @@ include_bsp_HEADERS += hwlib/include/hwlib.h
# Some of the headers from hwlib need the files from socal. Install them.
include_bsp_socal_HEADERS += hwlib/include/socal/alt_acpidmap.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_clkmgr.h
+include_bsp_socal_HEADERS += hwlib/include/socal/alt_dmanonsecure.h
+include_bsp_socal_HEADERS += hwlib/include/socal/alt_dmasecure.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_gpio.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_i2c.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_l3.h
+include_bsp_socal_HEADERS += hwlib/include/socal/alt_qspidata.h
+include_bsp_socal_HEADERS += hwlib/include/socal/alt_qspi.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_rstmgr.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_sdr.h
include_bsp_socal_HEADERS += hwlib/include/socal/alt_sysmgr.h
@@ -124,17 +130,18 @@ libbsp_a_CPPFLAGS += -std=gnu99
CFLAGS += -Wno-missing-prototypes
# hwlib from Altera
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_16550_uart.c
libbsp_a_SOURCES += hwlib/src/hwmgr/alt_address_space.c
libbsp_a_SOURCES += hwlib/src/hwmgr/alt_clock_manager.c
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_dma.c
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_dma_program.c
libbsp_a_SOURCES += hwlib/src/hwmgr/alt_generalpurpose_io.c
libbsp_a_SOURCES += hwlib/src/hwmgr/alt_i2c.c
+libbsp_a_SOURCES += hwlib/src/hwmgr/alt_qspi.c
libbsp_a_SOURCES += hwlib/src/hwmgr/alt_reset_manager.c
#The following Altera hwlib source files have been left out because so far
#they are not required:
-#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_16550_uart.c
#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_bridge_manager.c
-#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_dma_program.c
-#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_dma.c
#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_fpga_manager.c
#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_globaltmr.c
#libbsp_a_SOURCES += hwlib/src/hwmgr/alt_system_manager.c