summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-01-08 19:22:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-01-08 19:22:25 +0000
commit7af5e14dbf837958d91e6d317fedd8d997d2cdaf (patch)
tree606ce06f556448fa65bc56aedffc4e420d73140d /c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am
parent2001-01-08 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-7af5e14dbf837958d91e6d317fedd8d997d2cdaf.tar.bz2
2001-01-08 Joel Sherrill <joel@OARcorp.com>
* Shared memory support removed since it was non-functional. * shmsupp/.cvsignore, shmsupp/Makefile.am, shmsupp/addrconv.c, shmsupp/getcfg.c, shmsupp/lock.c, shmsupp/mpisr.c: Removed. * configure.in, Makefile.am, wrapup/Makefile.am: Modified to reflect above.
Diffstat (limited to 'c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am36
1 files changed, 0 insertions, 36 deletions
diff --git a/c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am b/c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am
deleted file mode 100644
index 30c8b19606..0000000000
--- a/c/src/lib/libbsp/a29k/portsw/shmsupp/Makefile.am
+++ /dev/null
@@ -1,36 +0,0 @@
-##
-## $Id$
-##
-
-AUTOMAKE_OPTIONS = foreign 1.4
-
-PGM = ${ARCH}/shmsupp.rel
-
-## C source names
-C_FILES = addrconv.c getcfg.c lock.c mpisr.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
-
-OBJS = $(C_O_FILES)
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../../../../automake/compile.am
-include $(top_srcdir)/../../../../../../automake/lib.am
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): ${OBJS}
- $(make-rel)
-
-if HAS_MP
-all-local: ${ARCH} $(PGM)
-else
-all-local:
-endif
-
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-
-EXTRA_DIST = addrconv.c getcfg.c lock.c mpisr.c
-
-include $(top_srcdir)/../../../../../../automake/local.am