summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/sys/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:25:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:25:50 +0000
commitf3d7592e22f7b42e6461ebe43046b646c02f4367 (patch)
treee74d202814ca590e6000c0e75cf00d7e658f55f6 /c/src/lib/include/sys/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f3d7592e22f7b42e6461ebe43046b646c02f4367.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/zilog/Makefile.am, include/Makefile.am, include/motorola/Makefile.am, include/sys/Makefile.am include/rtems/Makefile.am: Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to 'c/src/lib/include/sys/Makefile.am')
-rw-r--r--c/src/lib/include/sys/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/c/src/lib/include/sys/Makefile.am b/c/src/lib/include/sys/Makefile.am
index a9e3912b84..70929555a9 100644
--- a/c/src/lib/include/sys/Makefile.am
+++ b/c/src/lib/include/sys/Makefile.am
@@ -4,6 +4,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_sysdir = $(includedir)/sys
+
if HAS_NETWORKING
else
NETWORKING_H_FILES += ioctl.h
@@ -13,12 +15,13 @@ if NEWLIB
NEWLIB_H_FILES += termios.h cdefs.h
endif
-H_FILES = ioccom.h ttycom.h utime.h $(NEWLIB_H_FILES) $(NETWORKING_H_FILES)
+include_sys_HEADERS = ioccom.h ttycom.h utime.h \
+ $(NEWLIB_H_FILES) $(NETWORKING_H_FILES)
noinst_HEADERS = utime.h termios.h ioctl.h ioccom.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
+ $(include_sys_HEADERS:%=$(PROJECT_INCLUDE)/sys/%)
$(PROJECT_INCLUDE)/sys:
@$(mkinstalldirs) $@