summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-01 21:08:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-01 21:08:14 +0000
commit3ba74c733f4adf1d310a7e7ea4ddd2a0abc0b2fd (patch)
tree2849436d5bc8c06fa9b6dd522af3a539c043dc38 /c/src/lib/include/rtems/Makefile.am
parent2000-11-01 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-3ba74c733f4adf1d310a7e7ea4ddd2a0abc0b2fd.tar.bz2
2000-11-01 Joel Sherrill <joel@OARcorp.com>
* include/Makefile.am, include/rtems/libio_.h, libc/Makefile.am, libc/assoc.c, libc/assocnamebad.c, libc/base_fs.c, libc/cfsetispeed.c, libc/cfsetospeed.c, libc/chdir.c, libc/chmod.c, libc/chown.c, libc/close.c, libc/closedir.c, libc/dup2.c, libc/error.c, libc/eval.c, libc/fchdir.c, libc/fchmod.c, libc/fcntl.c, libc/fdatasync.c, libc/fpathconf.c, libc/fstat.c, libc/fsync.c, libc/ftruncate.c, libc/getdents.c, libc/ioctl.c, libc/libio.c, libc/libio_sockets.c, libc/link.c, libc/lseek.c, libc/malloc.c, libc/mallocfreespace.c, libc/mknod.c, libc/mount.c, libc/newlibc.c, libc/no_libc.c, libc/open.c, libc/read.c, libc/readlink.c, libc/rmdir.c, libc/stat.c, libc/symlink.c, libc/tcsetattr.c, libc/telldir.c, libc/ttyname.c, libc/ttyname_r.c, libc/umask.c, libc/unlink.c, libc/unmount.c, libc/utime.c, libc/write.c: assoc.h, error.h, libio_.h, libio.h, and libcsupport.h moved from libc to lib/include/rtems and now must be referenced as <rtems/XXX.h>. * include/rtems/Makefile.am, include/rtems/.cvsignore: New file. * include/rtems/assoc.h, include/rtems/error.h, include/rtems/libcsupport.h, include/rtems/libio.h, include/rtems/libio_.h: New/moved files.
Diffstat (limited to 'c/src/lib/include/rtems/Makefile.am')
-rw-r--r--c/src/lib/include/rtems/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/c/src/lib/include/rtems/Makefile.am b/c/src/lib/include/rtems/Makefile.am
new file mode 100644
index 0000000000..1b54a93c86
--- /dev/null
+++ b/c/src/lib/include/rtems/Makefile.am
@@ -0,0 +1,21 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = assoc.h error.h libcsupport.h libio.h libio_.h
+
+noinst_HEADERS = $(H_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am