summaryrefslogtreecommitdiffstats
path: root/c/src/lib/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-08-12 18:22:17 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-08-12 18:22:17 +0000
commitea562ee977d4b48500a9b117e543e9c4ae0eb05e (patch)
treeeece22c6292c13b788f7baafc4da8471283c0ff2 /c/src/lib/configure.in
parentPatch from Tony R. Ambardar <tonya@ece.ubc.ca>: (diff)
downloadrtems-ea562ee977d4b48500a9b117e543e9c4ae0eb05e.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
After upgrading my linux box to the brand new SuSE 6.2 release, which is glibc-2.1 based, I came across a bug in RTEMS - IIRC, I even warned you about it about 1/2 a year ago, but nothing has been done since then :-. The *.m4 macros to check for SYSV/IPC are broken for linux/glibc2.1, because they assume that linux always defines union semun, which isn't true anymore for glibc2.1 (the manpage for semctl states _X_OPEN specifies it this way). Therefore I have tried to implement a more general approach for handling SYSV for unix/posix which checks for presence of struct semun, instead of trying to evaluate OS specific preprocessor symbols. This approach is a bit adventureous, because I only tested it with linux/glibc2.1 and linux/libc5, but not under other Unix variants RTEMS supports. I am quite confident it will work on other hosts, too, but who knows :-. [FYI: I think this might also is the cause of some problems with RedHat 6.X / Mandrake linux recently reported on the rtems list -- rtems-4.0.0 can not be build for posix on any glibc2.1 based host] Furthermore the patch below contains a couple of minor fixes and configuration cleanups, which IMO should be applied before releasing a new snapshot. To apply this patch: cd <source-tree> patch -p1 < rtems-rc-19990709-8.diff ./autogen
Diffstat (limited to 'c/src/lib/configure.in')
-rw-r--r--c/src/lib/configure.in2
1 files changed, 0 insertions, 2 deletions
diff --git a/c/src/lib/configure.in b/c/src/lib/configure.in
index 69eafaf21c..39e5124109 100644
--- a/c/src/lib/configure.in
+++ b/c/src/lib/configure.in
@@ -44,8 +44,6 @@ dnl if this is an i386, does gas have good code16 support?
RTEMS_I386_GAS_CODE16
AM_CONDITIONAL(RTEMS_GAS_CODE16,test "$RTEMS_GAS_CODE16" = "yes");
-RTEMS_CHECK_SYSV_UNIX
-
# find all the Makefiles for the BSPs
makefiles="$makefiles libbsp/$RTEMS_CPU/Makefile"