summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
commitfba12eb6ff4a91fcbac1c43dd3196114cc12756b (patch)
tree34477c9b77ceab1ee81e0ea4a9ee9a6e3a3975cf /c/src/exec/wrapup/posix/Makefile.am
parentAdded projects chapter to FAQ. (diff)
downloadrtems-fba12eb6ff4a91fcbac1c43dd3196114cc12756b.tar.bz2
Patch rtems-rc-19991117-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
to convert the libc directory to automake and "dozens of small fixes for Makefile.ins/configure.ins below c/src/lib."
Diffstat (limited to 'c/src/exec/wrapup/posix/Makefile.am')
-rw-r--r--c/src/exec/wrapup/posix/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/exec/wrapup/posix/Makefile.am b/c/src/exec/wrapup/posix/Makefile.am
new file mode 100644
index 0000000000..d80634763d
--- /dev/null
+++ b/c/src/exec/wrapup/posix/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if HAS_POSIX
+LIBNAME = libposix
+LIB = $(ARCH)/$(LIBNAME).a
+endif
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+if HAS_POSIX
+
+POSIX_OBJS = $(wildcard ../../posix/src/$(ARCH)/*.o)
+
+OBJS = $(POSIX_OBJS)
+
+$(LIB): ${OBJS}
+ $(make-library)
+
+POSIX_LIB = \
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+all: ${ARCH} $(LIB) $(TMPINSTALL_FILES)
+
+endif
+
+TMPINSTALL_FILES += $(POSIX_LIB)
+
+include $(top_srcdir)/../../../automake/local.am