summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/macros/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-30 14:08:30 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-30 14:08:30 +0000
commit43b6f757ce6127d95778fe2eaa9e3a9fc3a06ae3 (patch)
treeb8cce290191ffcee0ce79451897a0ce89aec6af2 /c/src/exec/score/macros/rtems/score/Makefile.am
parent2000-11-30 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-43b6f757ce6127d95778fe2eaa9e3a9fc3a06ae3.tar.bz2
2000-11-30 Joel Sherrill <joel@OARcorp.com>
* General effort to make things compile with macros not inlines * inline/rtems/score/coremutex.inl: Added comment indicating for macros there is another copy of _CORE_mutex_Seize_interrupt_trylock() in src/coremutexseize.c. * src/coremutexseize.c: Added body of _CORE_mutex_Seize_interrupt_trylock() for macro case. * macros/rtems/score/coremutex.inl: Added prototype for _CORE_mutex_Seize_interrupt_trylock() since there is a real body when macros are enabled. * macros/rtems/score/coresem.inl: Added macro implementation of _CORE_semaphore_Seize_isr_disable. * macros/score/Makefile.am: Fixed typos. * rtems/score/address.inl: Correct macro implementation of _Addresses_Is_aligned() so it would compile. * macros/rtems/score/coremsg.inl: Added closing parentheses.
Diffstat (limited to 'c/src/exec/score/macros/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/macros/rtems/score/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/exec/score/macros/rtems/score/Makefile.am b/c/src/exec/score/macros/rtems/score/Makefile.am
index 4260e15c08..87cac6f169 100644
--- a/c/src/exec/score/macros/rtems/score/Makefile.am
+++ b/c/src/exec/score/macros/rtems/score/Makefile.am
@@ -18,11 +18,11 @@ if MACROS
if HAS_MP
I_FILES = $(STD_I_FILES) $(MP_I_FILES)
else
-I_FILES = $(STD_I_FILES
+I_FILES = $(STD_I_FILES)
endif
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/score%)
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
$(PROJECT_INCLUDE)/rtems/score:
@$(mkinstalldirs) $@