summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/powerpc/shared/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-02 17:45:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-02 17:45:14 +0000
commit432834560293094335873531fef84a4a98606180 (patch)
tree8b4084cfe8c4a0c1dc49a77b8553ca8644fadec5 /c/src/exec/score/cpu/powerpc/shared/Makefile.am
parentJennifer added initial test code. Conditional'ed out until she has (diff)
downloadrtems-432834560293094335873531fef84a4a98606180.tar.bz2
Patch rtems-rc-19991123-rc-2.diff from Ralf Corsepius
<corsepiu@faw.uni-ulm.de>: The patch below provides * automake support for score/cpu/powerpc * The hack to propagate values from *.cfg to automake configuration * A fix for librdbg/powerpc/mcp750/Makefile.am (Was completely corrupted before) * Fixes some files which apparently where missing in rtems-rc-19991123-rc-2.diff * some minor configuration related patches To apply: rm -rf ./c/src/exec/score/cpu/powerpc/wrap patch -p1 < rtems-rc-19991123-rc-3.diff Attention: c/src/exec/score/cpu/[configure.in|aclocal.m4|configure] should be removed after applying the patch.
Diffstat (limited to 'c/src/exec/score/cpu/powerpc/shared/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/powerpc/shared/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/powerpc/shared/Makefile.am b/c/src/exec/score/cpu/powerpc/shared/Makefile.am
new file mode 100644
index 0000000000..a2d0fb5f96
--- /dev/null
+++ b/c/src/exec/score/cpu/powerpc/shared/Makefile.am
@@ -0,0 +1,35 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+ROOT_H_FILES = asm.h
+RTEMS_SCORE_H_FILES = ppc.h ppctypes.h
+noinst_HEADERS = $(ROOT_H_FILES) $(RTEMS_SCORE_H_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE) \
+$(PROJECT_INCLUDE)/rtems/score \
+$(ROOT_H_FILES:%.h=$(PROJECT_INCLUDE)/%.h) \
+$(RTEMS_SCORE_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am