summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-07 19:36:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-07 19:36:14 +0000
commit80e53918dcb752cca5c435d3110069ae7c4b501e (patch)
tree4540035bf68959aaa7e2d0d3c2231ed8165c4026 /c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am
parentRemoved duplicate case values. (diff)
downloadrtems-80e53918dcb752cca5c435d3110069ae7c4b501e.tar.bz2
Moved old_exception_processing and new_exception_processing directories
from score/cpu to libcpu because the determination of which to use is based on RTEMS_CPU_MODEL. Thus it can not be determined based solely on multilib information.
Diffstat (limited to 'c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am b/c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am
index 1f4affe8f4..f6b84c4969 100644
--- a/c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am
+++ b/c/src/exec/score/cpu/powerpc/new_exception_processing/Makefile.am
@@ -3,6 +3,7 @@
##
AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
@@ -15,7 +16,7 @@ S_FILES = cpu_asm.S
S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../../../../automake/lib.am
+include $(top_srcdir)/../../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
@@ -25,12 +26,6 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/rtems/score \
$(ROOT_H_FILES:%=$(PROJECT_INCLUDE)/%) \
$(RTEMS_SCORE_H_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
-##TMPINSTALL_FILES += \
-##$(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o
-
-##$(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
-## $(INSTALL_DATA) $< $@
-
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -57,4 +52,4 @@ CLEANDIRS = ../o-optimize ../o-debug ../o-profile
EXTRA_DIST = $(C_FILES) $(S_FILES)
-include $(top_srcdir)/../../../../../../automake/local.am
+include $(top_srcdir)/../../../../../automake/local.am