summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/or32/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-08-11 21:59:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-08-11 21:59:52 +0000
commit5377fed341a361bc3c2fc35629361597777cb42a (patch)
treeaa85ca35818933e6639707637714793e9bc20a9d /c/src/exec/score/cpu/or32/rtems/score/Makefile.am
parent2000-08-11 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-5377fed341a361bc3c2fc35629361597777cb42a.tar.bz2
2000-08-11 Joel Sherrill <joel@OARcorp.com>
* Shell added for or32 port based on no_cpu port with names replaced.
Diffstat (limited to 'c/src/exec/score/cpu/or32/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/or32/rtems/score/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/or32/rtems/score/Makefile.am b/c/src/exec/score/cpu/or32/rtems/score/Makefile.am
new file mode 100644
index 0000000000..06c68ef018
--- /dev/null
+++ b/c/src/exec/score/cpu/or32/rtems/score/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = cpu.h or32.h cpu_asm.h or32types.h
+noinst_HEADERS = $(H_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am