summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/or32/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-08-11 21:59:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-08-11 21:59:52 +0000
commit5377fed341a361bc3c2fc35629361597777cb42a (patch)
treeaa85ca35818933e6639707637714793e9bc20a9d /c/src/exec/score/cpu/or32/Makefile.am
parent2000-08-11 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-5377fed341a361bc3c2fc35629361597777cb42a.tar.bz2
2000-08-11 Joel Sherrill <joel@OARcorp.com>
* Shell added for or32 port based on no_cpu port with names replaced.
Diffstat (limited to 'c/src/exec/score/cpu/or32/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/or32/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/or32/Makefile.am b/c/src/exec/score/cpu/or32/Makefile.am
new file mode 100644
index 0000000000..b055a2d202
--- /dev/null
+++ b/c/src/exec/score/cpu/or32/Makefile.am
@@ -0,0 +1,46 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+SUBDIRS = rtems
+
+C_FILES = cpu.c cpu_asm.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+H_FILES = asm.h
+
+REL = $(ARCH)/rtems-cpu.rel
+
+rtems_cpu_rel_OBJECTS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
+ $(INSTALL_DATA) $< $@
+
+$(REL): $(rtems_cpu_rel_OBJECTS)
+ $(make-rel)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(H_FILES:%=$(PROJECT_INCLUDE)/%)
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
+ $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(REL)
+
+EXTRA_DIST = asm.h cpu.c cpu_asm.c rtems.c
+
+include $(top_srcdir)/../../../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../../../automake/local.am