summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/h8300/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-29 23:00:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-29 23:00:48 +0000
commit5532553209555c0a5a3c11206ff16192dd465160 (patch)
tree82b8bea30e32fb1928cb4e26f5d5415ff84ea42a /c/src/exec/score/cpu/h8300/rtems/score/Makefile.am
parentUsing RPM names for versions now. (diff)
downloadrtems-5532553209555c0a5a3c11206ff16192dd465160.tar.bz2
This is the initial addition of the port of RTEMS to the
Hitachi H8 family. This port was done by Philip Quaife <philip@qs.co.nz> of Q Solutions and sponsored by Comnet Technologies Ltd. The port was done based on RTEMS 3.5.1 to a Hitach H8300H. The port was updated to RTEMS 4.5 style Makefiles/configure by Joel Sherrill <joel@OARcorp.com>. While doing this Joel added support for the h8300-rtems to binutils, gcc, newlib, and gdb. NOTE: Philip submitted a BSP for a Hitachi evaluation board which is being merged as a separate entity.
Diffstat (limited to 'c/src/exec/score/cpu/h8300/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/h8300/rtems/score/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/h8300/rtems/score/Makefile.am b/c/src/exec/score/cpu/h8300/rtems/score/Makefile.am
new file mode 100644
index 0000000000..a21ad00f85
--- /dev/null
+++ b/c/src/exec/score/cpu/h8300/rtems/score/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = cpu.h h8300.h h8300types.h
+noinst_HEADERS = $(H_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am