summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/h8300/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-29 23:00:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-29 23:00:48 +0000
commit5532553209555c0a5a3c11206ff16192dd465160 (patch)
tree82b8bea30e32fb1928cb4e26f5d5415ff84ea42a /c/src/exec/score/cpu/h8300/configure.in
parentUsing RPM names for versions now. (diff)
downloadrtems-5532553209555c0a5a3c11206ff16192dd465160.tar.bz2
This is the initial addition of the port of RTEMS to the
Hitachi H8 family. This port was done by Philip Quaife <philip@qs.co.nz> of Q Solutions and sponsored by Comnet Technologies Ltd. The port was done based on RTEMS 3.5.1 to a Hitach H8300H. The port was updated to RTEMS 4.5 style Makefiles/configure by Joel Sherrill <joel@OARcorp.com>. While doing this Joel added support for the h8300-rtems to binutils, gcc, newlib, and gdb. NOTE: Philip submitted a BSP for a Hitachi evaluation board which is being merged as a separate entity.
Diffstat (limited to 'c/src/exec/score/cpu/h8300/configure.in')
-rw-r--r--c/src/exec/score/cpu/h8300/configure.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/h8300/configure.in b/c/src/exec/score/cpu/h8300/configure.in
new file mode 100644
index 0000000000..1d9b92d6ef
--- /dev/null
+++ b/c/src/exec/score/cpu/h8300/configure.in
@@ -0,0 +1,34 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(cpu_asm.S)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-score-cpu-h8300,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_NEWLIB
+
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
+# Explicitly list all Makefiles here
+AC_OUTPUT(
+Makefile
+rtems/Makefile
+rtems/score/Makefile)