summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-03 13:25:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-03 13:25:00 +0000
commit4090ebe85c7947db664c0839a2090d0076b7a9da (patch)
tree2b4da1cedd0f57025349b891bca545716fd37928 /c/src/exec/score/cpu/configure.in
parentPatch from Rosimildo DaSilva <rdasilva@connecttel.com> for Cygwin (diff)
downloadrtems-4090ebe85c7947db664c0839a2090d0076b7a9da.tar.bz2
Patch rtems-rc-19991123-rc-3.diff from Ralf Corsepius
<corsepiu@faw.uni-ulm.de>: The patch below provides * automake support for score/cpu/powerpc * The hack to propagate values from *.cfg to automake configuration * A fix for librdbg/powerpc/mcp750/Makefile.am (Was completely corrupted before) * Fixes some files which apparently where missing in rtems-rc-19991123-rc-2.diff * some minor configuration related patches To apply: rm -rf ./c/src/exec/score/cpu/powerpc/wrap patch -p1 < rtems-rc-19991123-rc-3.diff Attention: c/src/exec/score/cpu/[configure.in|aclocal.m4|configure] should be removed after applying the patch. Modifications had been made to the score/cpu/powerpc directory after the snapshot this was based on. In particular, the mpc750 and other_cpu directories had been renamed to new_exception_processing and old_exception_processing. After this patch was applied, modifications were made to account for this.
Diffstat (limited to 'c/src/exec/score/cpu/configure.in')
-rw-r--r--c/src/exec/score/cpu/configure.in62
1 files changed, 0 insertions, 62 deletions
diff --git a/c/src/exec/score/cpu/configure.in b/c/src/exec/score/cpu/configure.in
deleted file mode 100644
index de885e607e..0000000000
--- a/c/src/exec/score/cpu/configure.in
+++ /dev/null
@@ -1,62 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-dnl
-dnl $Id$
-
-AC_PREREQ(2.13)
-AC_INIT(no_cpu)
-RTEMS_TOP(../../../../..)
-AC_CONFIG_AUX_DIR(../../../../..)
-
-AC_PROG_MAKE_SET
-RTEMS_CANONICAL_TARGET_CPU
-
-AM_MAINTAINER_MODE
-RTEMS_ENABLE_MULTIPROCESSING
-RTEMS_ENABLE_POSIX
-RTEMS_ENABLE_ITRON
-RTEMS_ENABLE_INLINES
-RTEMS_ENABLE_LIBCDIR
-
-RTEMS_ENV_RTEMSBSP
-
-AC_PROG_INSTALL
-
-RTEMS_CHECK_CPU
-RTEMS_CANONICAL_HOST
-
-RTEMS_PROJECT_ROOT
-
-dnl check target cc
-RTEMS_PROG_CC_FOR_TARGET
-RTEMS_CANONICALIZE_TOOLS
-
-RTEMS_CHECK_NEWLIB
-
-# Check if there is custom/*.cfg for this BSP
-RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
-RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
-RTEMS_CHECK_POSIX_API(RTEMS_BSP)
-RTEMS_CHECK_ITRON_API(RTEMS_BSP)
-
-# The only use of System V IPC is the UNIX port when multiprocessing.
-if test "$HAS_MP" = "yes"; then
- RTEMS_CHECK_SYSV_UNIX
-fi
-
-# find all the Executive Makefiles
-if test -f $srcdir/$RTEMS_CPU/configure; then
-cfg_subdirs="$RTEMS_CPU"
-else
-RTEMS_CHECK_MAKEFILE($RTEMS_CPU)
-fi
-
-AC_CONFIG_SUBDIRS($cfg_subdirs)
-
-AM_CONDITIONAL(HAS_POSIX,test "$HAS_POSIX_API" = "yes")
-AM_CONDITIONAL(HAS_ITRON,test "$HAS_ITRON_API" = "yes")
-
-# Try to explicitly list a Makefile here
-AC_OUTPUT(
-Makefile
-$makefiles
-)