summaryrefslogtreecommitdiffstats
path: root/c/src/exec/sapi/include/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-22 09:46:48 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-22 09:46:48 +0000
commit2b3e9d9b244e279ef5693a7cf5dacc7903164af5 (patch)
tree955e5242d4d08a8ec747c8350f55003bb9d4b519 /c/src/exec/sapi/include/Makefile.am
parentRemove everything. (diff)
downloadrtems-2b3e9d9b244e279ef5693a7cf5dacc7903164af5.tar.bz2
Remove, moved to cpukit.
Diffstat (limited to 'c/src/exec/sapi/include/Makefile.am')
-rw-r--r--c/src/exec/sapi/include/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/c/src/exec/sapi/include/Makefile.am b/c/src/exec/sapi/include/Makefile.am
deleted file mode 100644
index b41bb64295..0000000000
--- a/c/src/exec/sapi/include/Makefile.am
+++ /dev/null
@@ -1,34 +0,0 @@
-##
-## $Id$
-##
-
-
-$(PROJECT_INCLUDE):
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems:
- @$(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-include_HEADERS = confdefs.h
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE) \
- $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-include_rtemsdir = $(includedir)/rtems
-
-include_rtems_HEADERS = rtems/config.h rtems/extension.h rtems/fatal.h \
- rtems/init.h rtems/io.h rtems/mptables.h rtems/sptables.h
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
- $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-EXTRA_DIST = rtems/README
-
-rtems/sptables.h: $(top_builddir)/config.status $(top_srcdir)/sapi/include/rtems/sptables.h.in
- cd $(top_builddir) && CONFIG_FILES=sapi/include/$@ CONFIG_HEADERS= CONFIG_LINKS= $(SHELL) ./config.status
-
-all-local: $(PREINSTALL_FILES)
-
-include $(top_srcdir)/automake/local.am