summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-01 18:57:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-01 18:57:36 +0000
commit2b2bda48c1909457cfff0132ed346fe5578f6e03 (patch)
treeeb5d4e88b58a35f5ac2fdc1d462f81b709381a38 /c/src/exec/posix/configure.in
parent2000-11-30 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-2b2bda48c1909457cfff0132ed346fe5578f6e03.tar.bz2
2000-12-01 Joel Sherrill <joel@OARcorp.com>
* Added macro support to POSIX API. This is known to compile. * macros/rtems/posix/cond.inl, macros/rtems/posix/intr.inl, macros/rtems/posix/key.inl, macros/rtems/posix/mqueue.inl, macros/rtems/posix/mutex.inl, macros/rtems/posix/priority.inl, macros/rtems/posix/pthread.inl, macros/rtems/posix/semaphore.inl, macros/rtems/posix/timer.inl: New files. * configure.in: Removed error check for enabling macros. * rtems/posix/mutex.h: #if 0'ed out prototypes for inlined routines since you cannot have prototypes for macros. * macros/rtems/posix/Makefile.am: Added files.
Diffstat (limited to 'c/src/exec/posix/configure.in')
-rw-r--r--c/src/exec/posix/configure.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/c/src/exec/posix/configure.in b/c/src/exec/posix/configure.in
index 69ac564fda..4151c6f80d 100644
--- a/c/src/exec/posix/configure.in
+++ b/c/src/exec/posix/configure.in
@@ -31,10 +31,6 @@ RTEMS_CHECK_POSIX_API(RTEMS_BSP)
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
INLINEdir="macros"
- if test "$HAS_POSIX_API" = "yes"; then
- # The problem is that there is currently no code in posix/macros :)
- AC_MSG_ERROR(Macros are not implemented for the POSIX API)
- fi
else
INLINEdir="inline"
fi
@@ -50,12 +46,6 @@ if test "$HAS_POSIX_API" != "yes"; then
AC_MSG_ERROR([BSP $RTEMS_BSP does not support libposix])
fi
-# If RTEMS macros are enabled, then use them. Otherwise, refuse to build
-if test "$RTEMS_USE_MACROS" = "yes"; then
-# The problem is that there is currently no code in posix/macros :)
-AC_MSG_ERROR(Macros are not implemented for the POSIX API)
-fi
-
# Explicitly list all Makefiles here
AC_OUTPUT(
Makefile