summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libcsupport/src/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-14 19:02:06 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-14 19:02:06 +0000
commitbaf7133855d07a897c5337b5860b6e9c61482d2f (patch)
tree8fa971de8e3d73a4a7a88d950566354a573f48f4 /c/src/exec/libcsupport/src/Makefile.am
parent2002-05-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-baf7133855d07a897c5337b5860b6e9c61482d2f.tar.bz2
2001-05-14 Till Straumann <strauman@slac.stanford.edu>
* Per PR212, added envlock support for newlib. This is used by at least getenv()/putenv() to avoid race conditions. * libc/envlock.c: New file. * libc/Makefile.am: Modified to reflect above.
Diffstat (limited to 'c/src/exec/libcsupport/src/Makefile.am')
-rw-r--r--c/src/exec/libcsupport/src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/exec/libcsupport/src/Makefile.am b/c/src/exec/libcsupport/src/Makefile.am
index 630522af4c..075f97731f 100644
--- a/c/src/exec/libcsupport/src/Makefile.am
+++ b/c/src/exec/libcsupport/src/Makefile.am
@@ -34,6 +34,8 @@ DIRECTORY_SCAN_C_FILES = opendir.c closedir.c readdir.c rewinddir.c \
MALLOC_C_FILES = malloc.c mallocfreespace.c __brk.c __sbrk.c
+ENVIRON_C_FILES = envlock.c
+
PASSWORD_GROUP_C_FILES = getpwent.c getgrent.c
TERMINAL_IDENTIFICATION_C_FILES = ctermid.c isatty.c ttyname.c ttyname_r.c
@@ -44,7 +46,7 @@ LIBC_GLUE_C_FILES = __getpid.c __gettod.c __times.c truncate.c access.c \
UNIX_LIBC_C_FILES = unixlibc.c hosterr.c
COMMON_C_FILES = gxx_wrappers.c printk.c $(BASE_FS_C_FILES) \
- $(MALLOC_C_FILES) $(TERMIOS_C_FILES) $(ERROR_C_FILES) \
+ $(MALLOC_C_FILES) $(ENVIRON_C_FILES) $(TERMIOS_C_FILES) $(ERROR_C_FILES) \
$(ASSOCIATION_C_FILES)
UNIX_C_FILES = $(UNIX_LIBC_C_FILES)