summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/include/rtems/itron/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-09 22:07:23 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-09 22:07:23 +0000
commit352c9b2035e32e56f10f261d94955d97f4ab0f1c (patch)
treef433e95ae0ab8d8854ea19b7f4bfab3ffb431726 /c/src/exec/itron/include/rtems/itron/Makefile.am
parentFixed warning where initialized default POSIX API structure did (diff)
downloadrtems-352c9b2035e32e56f10f261d94955d97f4ab0f1c.tar.bz2
This patch adds the basic framework for the ITRON 3.0 API implementation
for RTEMS.
Diffstat (limited to 'c/src/exec/itron/include/rtems/itron/Makefile.am')
-rw-r--r--c/src/exec/itron/include/rtems/itron/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/exec/itron/include/rtems/itron/Makefile.am b/c/src/exec/itron/include/rtems/itron/Makefile.am
new file mode 100644
index 0000000000..d295a8b02d
--- /dev/null
+++ b/c/src/exec/itron/include/rtems/itron/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_PIECES = config.h eventflags.h fmempool.h intr.h itronapi.h mbox.h \
+ msgbuffer.h network.h object.h port.h semaphore.h sysmgmt.h \
+ task.h time.h vmempool.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/itron \
+$(H_PIECES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
+
+$(PROJECT_INCLUDE)/rtems/itron:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/itron/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+EXTRA_DIST = README
+
+include $(top_srcdir)/../../../../automake/local.am