summaryrefslogtreecommitdiffstats
path: root/c/src/exec/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:31:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:31:45 +0000
commit81d4759187ad0fa8e19f22c73a738f2553857286 (patch)
treeca75c9005b026fc8cc4318b1d2b4b9fc99b4e3b3 /c/src/exec/configure.ac
parent2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-81d4759187ad0fa8e19f22c73a738f2553857286.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Use AC_CONFIG_SUBDIRS for posix and itron. Reflect changes to configuration of rtems, score and sapi subdirs.
Diffstat (limited to 'c/src/exec/configure.ac')
-rw-r--r--c/src/exec/configure.ac20
1 files changed, 2 insertions, 18 deletions
diff --git a/c/src/exec/configure.ac b/c/src/exec/configure.ac
index 92969c9a83..ea637bdaf1 100644
--- a/c/src/exec/configure.ac
+++ b/c/src/exec/configure.ac
@@ -54,12 +54,11 @@ AM_CONDITIONAL(HAS_POSIX,test "$HAS_POSIX_API" = "yes")
AM_CONDITIONAL(HAS_ITRON,test "$HAS_ITRON_API" = "yes")
if test "$HAS_POSIX_API" = "yes"; then
- cfg_subdirs="posix"
+ AC_CONFIG_SUBDIRS(posix)
fi
if test "$HAS_ITRON_API" = "yes"; then
- cfg_subdirs="$cfg_subdirs itron"
+ AC_CONFIG_SUBDIRS(itron)
fi
-AC_CONFIG_SUBDIRS($cfg_subdirs)
AC_CONFIG_SUBDIRS(score/cpu/$RTEMS_CPU)
RTEMS_DEFINE_POSIX_API
@@ -78,36 +77,21 @@ AC_CONFIG_FILES([Makefile
rtems/Makefile
rtems/src/Makefile
rtems/include/Makefile
-rtems/include/rtems/Makefile
-rtems/include/rtems/rtems/Makefile
rtems/optman/Makefile
rtems/inline/Makefile
-rtems/inline/rtems/Makefile
-rtems/inline/rtems/rtems/Makefile
rtems/macros/Makefile
-rtems/macros/rtems/Makefile
-rtems/macros/rtems/rtems/Makefile
sapi/Makefile
sapi/src/Makefile
sapi/include/Makefile
-sapi/include/rtems/Makefile
sapi/include/rtems/sptables.h
sapi/inline/Makefile
-sapi/inline/rtems/Makefile
sapi/macros/Makefile
-sapi/macros/rtems/Makefile
sapi/optman/Makefile
score/Makefile
score/cpu/Makefile
score/include/Makefile
-score/include/rtems/Makefile
-score/include/rtems/score/Makefile
score/inline/Makefile
-score/inline/rtems/Makefile
-score/inline/rtems/score/Makefile
score/macros/Makefile
-score/macros/rtems/Makefile
-score/macros/rtems/score/Makefile
score/src/Makefile
wrapup/Makefile
wrapup/rtems/Makefile