summaryrefslogtreecommitdiffstats
path: root/c/src/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-09-07 13:45:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-09-07 13:45:03 +0000
commite1d8abbe2800defb344dcce54c401733edd1d37a (patch)
tree56e416222d2ed47222be37f868a06c93656edc72 /c/src/configure.in
parentRemoved by patch rtems-rc-19990820-6.diff.gz from (diff)
downloadrtems-e1d8abbe2800defb344dcce54c401733edd1d37a.tar.bz2
Applied patch rtems-rc-19990820-6.diff.gz from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> which converted many Makefile.in's to Makefile.am's. This added a lot of files.
Diffstat (limited to 'c/src/configure.in')
-rw-r--r--c/src/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/c/src/configure.in b/c/src/configure.in
index f94b5e04ba..cdc548910a 100644
--- a/c/src/configure.in
+++ b/c/src/configure.in
@@ -7,6 +7,8 @@ AC_INIT(exec)
RTEMS_TOP(../..)
AC_CONFIG_AUX_DIR(../..)
+RTEMS_ENABLE_CXX
+
RTEMS_CANONICAL_TARGET_CPU
AM_INIT_AUTOMAKE(rtems-c-src,$RTEMS_VERSION,no)
@@ -20,10 +22,14 @@ RTEMS_PROJECT_ROOT
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+## Note: the order of the directories below is essential
AC_CONFIG_SUBDIRS(make)
AC_CONFIG_SUBDIRS(exec)
AC_CONFIG_SUBDIRS(lib)
-AC_CONFIG_SUBDIRS(librtems++)
+if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
+cfg_subdirs="librtems++";
+fi
+AC_CONFIG_SUBDIRS($cfg_subdirs)
AC_CONFIG_SUBDIRS(tests)
AC_OUTPUT(