summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-11 00:03:43 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-11 00:03:43 +0000
commite42cb8bc057b08308f1e9ede4588f1ccfac50f5b (patch)
tree953b4507a6fb25c8b6edbd33c8ecbe0db65312c7 /c/src/configure.ac
parent2003-11-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e42cb8bc057b08308f1e9ede4588f1ccfac50f5b.tar.bz2
2003-11-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Reflect having moved tests to ../../testsuites.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 48a18cb62a..31e3a6d5ec 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -174,9 +174,11 @@ AS_IF([test x"$enable_ada" = x"yes"],[
])
])
-AS_IF([test -d ${srcdir}/tests],[
- AC_CONFIG_SUBDIRS([tests])
- BSP_SUBDIRS="$BSP_SUBDIRS tests"
+AS_IF([test -d ${srcdir}/../../testsuites],[
+ RTEMS_CONFIG_SUBDIR([testsuites],[../../testsuites],
+ ['--with-project-root=../../' '--enable-rtemsbsp=$RTEMS_BSP'
+ ])
+ BSP_SUBDIRS="$BSP_SUBDIRS testsuites"
])
AC_SUBST([BSP_SUBDIRS],[$BSP_SUBDIRS])