summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-03-25 11:09:19 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-03-25 11:09:19 +0000
commit8ae203e3a6aaf2d0c60374c732356ff67bc4ab80 (patch)
tree78d253faa579821f6d9487dd457b4c8baab57c6b /c/src/configure.ac
parent2004-03-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8ae203e3a6aaf2d0c60374c732356ff67bc4ab80.tar.bz2
2004-03-25 Ralf Corsepius <ralf_corsepius@rtems.org>
* configure.ac: Reflect changes to testsuites's configuration.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac22
1 files changed, 16 insertions, 6 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 5bbd2c3670..0ab402ec50 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -168,17 +168,27 @@ AC_ARG_ENABLE([ada],
*) AC_MSG_ERROR(bad value ${enable_ada} for --enable-ada) ;;
esac],[enable_ada=no])
+# FIXME: We should compute project_top from target-subdir
+if test -n "$with_target_subdir"; then
+project_top=../../../../
+else
+project_top=../../../
+fi
AS_IF([test x"$enable_ada" = x"yes"],[
- AS_IF([test -d ${srcdir}/ada-tests],[
- AC_CONFIG_SUBDIRS([ada-tests])
- BSP_SUBDIRS="$BSP_SUBDIRS ada-tests"
- ])
+ RTEMS_BSP_CONFIG_SUBDIR(
+ [ada-tests],[ada-tests],
+ ['--with-project-top=$project_top' \
+ '--enable-rtems-root=../' \
+ '--with-project-root=../../../' \
+ '--enable-rtemsbsp=$RTEMS_BSP' \
+ ],
+ [test x"$enable_tests" != x"no"])
])
RTEMS_BSP_CONFIG_SUBDIR(
[testsuites],[../../testsuites],
- ['--with-target-subdir=$with_target_subdir/c/$RTEMS_BSP' \
- '--with-rtems-root=../' \
+ ['--with-project-top=$project_top' \
+ '--enable-rtems-root=../' \
'--with-project-root=../../../' \
'--enable-rtemsbsp=$RTEMS_BSP' \
],