summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-14 09:44:51 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-14 09:44:51 +0000
commit832bed1b800cdcbd73f3c0f617b0c14583a8f44f (patch)
tree04ee5c10e5773ad7c46d946677b35ae76e959dfd /c/src/configure.ac
parent2004-02-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-832bed1b800cdcbd73f3c0f617b0c14583a8f44f.tar.bz2
2004-02-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* librdbg/src/i386/Makefile.am, librdbg/src/m68k/Makefile.am, librdbg/src/powerpc/Makefile.am: Remove. * librdbg/src/Makefile.am: Merge-in librdbg/src/i386/Makefile.am, librdbg/src/m68k/Makefile.am, librdbg/src/powerpc/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index b01f05d4a8..4fe403a43a 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -154,7 +154,7 @@ BSP_SUBDIRS="$BSP_SUBDIRS lib"
BSP_SUBDIRS="$BSP_SUBDIRS libchip"
BSP_SUBDIRS="$BSP_SUBDIRS libnetworking"
BSP_SUBDIRS="$BSP_SUBDIRS librdbg"
-
+
AS_IF([test "$RTEMS_HAS_CPLUSPLUS" = "yes"],[
AC_CONFIG_SUBDIRS([librtems++])
BSP_SUBDIRS="$BSP_SUBDIRS librtems++"
@@ -195,7 +195,16 @@ AS_IF([test "$host_cpu" = "sparc"],[
])
AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
+
+# FIXME: This is sick
AM_CONDITIONAL([HAS_RDBG],[test "$HAS_RDBG" = "yes"])
+AM_CONDITIONAL([HAS_RDBG_i386],[test "$HAS_RDBG" = "yes" \
+ && test $RTEMS_CPU = "i386"])
+AM_CONDITIONAL([HAS_RDBG_m68k],[test "$HAS_RDBG" = "yes" \
+ && test $RTEMS_CPU = "m68k"])
+AM_CONDITIONAL([HAS_RDBG_powerpc],[test "$HAS_RDBG" = "yes" \
+ && test $RTEMS_CPU = "powerpc"])
+
AM_CONDITIONAL(HAS_POSIX,test "$HAS_POSIX_API" = "yes")
# The posix bsp doesn't support libchip
@@ -242,9 +251,6 @@ libnetworking/rtems_webserver/Makefile
librdbg/Makefile
librdbg/include/Makefile
librdbg/src/Makefile
-librdbg/src/i386/Makefile
-librdbg/src/powerpc/Makefile
-librdbg/src/m68k/Makefile
libchip/Makefile