summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-12 14:29:54 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-12 14:29:54 +0000
commit67bfd9a63ee473f71a19279657ddbf40e46cca0c (patch)
tree80d64036aa02ac19afb86df6e93777d8e3ccd6d8 /c/src/configure.ac
parent2002-08-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-67bfd9a63ee473f71a19279657ddbf40e46cca0c.tar.bz2
2002-08-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
Posix-BSP-Hacks: * configure.ac: Add AM_CONDITIONAL(LIBCHIP). Pass RTEMS_HOST to make/bsp.mak * Makefile.am: Pass RTEMS_HOST to make/bsp.mak. * wrapup/Makefile.am: Apply AM_CONDITIONAL(LIBCHIP).
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index f384afa114..20f454ac27 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -54,6 +54,7 @@ cp ${srcdir}/make/custom/default.cfg.in make/custom/default.cfg
AC_MSG_NOTICE([creating make/${RTEMS_BSP}.cache])
${MAKE-make} -f ${srcdir}/make/bsp.mak \
RTEMS_BSP=${RTEMS_BSP} \
+RTEMS_HOST=${RTEMS_HOST} \
BARE_CPU_MODEL=${BARE_CPU_MODEL} \
RTEMS_ROOT=. make/${RTEMS_BSP}.cache
@@ -114,8 +115,12 @@ BSP_SUBDIRS="$BSP_SUBDIRS tests"
AC_SUBST([BSP_SUBDIRS],[$BSP_SUBDIRS])
-AM_CONDITIONAL(HAS_NETWORKING, test "$HAS_NETWORKING" = "yes" )
-AM_CONDITIONAL(HAS_RDBG, test "$HAS_RDBG" = "yes" )
+AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
+AM_CONDITIONAL([HAS_RDBG],[test "$HAS_RDBG" = "yes"])
+
+# The posix bsp doesn't support libchip
+# FIXME: We should use a feature based check, here
+AM_CONDITIONAL([LIBCHIP],[test "$RTEMS_BSP_FAMILY" != "posix"])
# The bare bsp doesn't have libbsp.a
# FIXME: We should use a feature based check, here