summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-08-10 13:28:50 +1000
committerChris Johns <chrisj@rtems.org>2016-08-11 17:24:06 +1000
commit03c1038edbe9b01a72d4775dcb6ffc1a03193a0c (patch)
treee82822781679566a6a824211492e8f8cd98f16b6 /c/src/configure.ac
parentbuild-system: Always enable C++ if the compiler is present. (diff)
downloadrtems-03c1038edbe9b01a72d4775dcb6ffc1a03193a0c.tar.bz2
librtems++: Remove from RTEMS.
This is old and there are better design patterns for threading and C++. We recommend you use the new C++ standards based support. Closes #2777.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 6b34eb54f4..1543b5dc28 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -140,12 +140,6 @@ AC_SUBST(libbsp_cpu_subdir,$RTEMS_CPU)
BSP_SUBDIRS="$BSP_SUBDIRS lib"
BSP_SUBDIRS="$BSP_SUBDIRS libchip"
-
-AS_IF([test "$RTEMS_HAS_CPLUSPLUS" = "yes"],[
- AC_CONFIG_SUBDIRS([librtems++])
- BSP_SUBDIRS="$BSP_SUBDIRS librtems++"
-])
-
BSP_SUBDIRS="$BSP_SUBDIRS support"
BSP_SUBDIRS="$BSP_SUBDIRS ada"
BSP_SUBDIRS="$BSP_SUBDIRS wrapup"