summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-10-19 13:41:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-10-19 13:41:08 +0000
commit003888531f09e884f30e5cac63d199531029f9b8 (patch)
treec3a8d73a2f69f6b30382a54d493b7d2ac4868b38 /c/src/configure.ac
parent2003-10-17 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-003888531f09e884f30e5cac63d199531029f9b8.tar.bz2
2003-10-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Make presence of tests/ optional.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 667420e7a3..6613eaf612 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -166,8 +166,10 @@ AS_IF([test x"$enable_ada" = x"yes"],[
])
])
-AC_CONFIG_SUBDIRS([tests])
-BSP_SUBDIRS="$BSP_SUBDIRS tests"
+AS_IF([test -d ${srcdir}/tests],[
+ AC_CONFIG_SUBDIRS([tests])
+ BSP_SUBDIRS="$BSP_SUBDIRS tests"
+])
AC_SUBST([BSP_SUBDIRS],[$BSP_SUBDIRS])