summaryrefslogtreecommitdiffstats
path: root/c/src/ada-tests/sptests/sp01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-03 22:51:40 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-03 22:51:40 +0000
commit0f9e7f9670cf6c36cf34b4ad5e18e8d7ee0244a8 (patch)
tree8428a26d24d8ee5aa10f6c672dc020b93c1160d8 /c/src/ada-tests/sptests/sp01/Makefile.am
parent2003-01-03 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-0f9e7f9670cf6c36cf34b4ad5e18e8d7ee0244a8.tar.bz2
2003-01-03 Joel Sherrill <joel@OARcorp.com>
* ada.am, samples/ticker/Makefile.am, sptests/sp01/Makefile.am, sptests/sp01/config.h, sptests/sp04/Makefile.am, sptests/sp04/config.h, support/init.c: Modified build rules slightly so gnat_main is used as the Ada main entry point. Modified sp01 and sp04 Makefile.am's to compile and link with init.o. The test config.h's specified the Ada application requirements -- not the Classic API ones.
Diffstat (limited to 'c/src/ada-tests/sptests/sp01/Makefile.am')
-rw-r--r--c/src/ada-tests/sptests/sp01/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/ada-tests/sptests/sp01/Makefile.am b/c/src/ada-tests/sptests/sp01/Makefile.am
index f29bf0af06..a69f6a5782 100644
--- a/c/src/ada-tests/sptests/sp01/Makefile.am
+++ b/c/src/ada-tests/sptests/sp01/Makefile.am
@@ -1,5 +1,7 @@
## $Id$
+VPATH = @srcdir@:@srcdir@/../../support
+
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
@@ -9,7 +11,7 @@ include $(top_srcdir)/ada.am
noinst_PROGRAMS = sp01
sp01_SOURCES = sp01.adb config.h sptest.adb sptest.ads
-sp01$(EXEEXT): sp01.adb
+sp01$(EXEEXT): sp01.adb init.o
$(GNATCOMPILE) -margs -a $< -o $@
EXTRA_DIST = sp01.scn