summaryrefslogtreecommitdiffstats
path: root/c/src/ada-tests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-03 21:14:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-03 21:14:04 +0000
commitea14663edc68e19c7e0f05736e8ce51891bee51f (patch)
treed8dfb85a76eb58fb1bbb1d19067b28b646a01e87 /c/src/ada-tests/configure.ac
parent2002-10-31 Chris Johns <ccj@acm.org> (diff)
downloadrtems-ea14663edc68e19c7e0f05736e8ce51891bee51f.tar.bz2
2003-01-03 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, configure.ac, samples/Makefile.am: Do not configure them unless multiprocessing is enabled.
Diffstat (limited to 'c/src/ada-tests/configure.ac')
-rw-r--r--c/src/ada-tests/configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/c/src/ada-tests/configure.ac b/c/src/ada-tests/configure.ac
index 9c177a1537..f35f1b29ec 100644
--- a/c/src/ada-tests/configure.ac
+++ b/c/src/ada-tests/configure.ac
@@ -23,11 +23,14 @@ RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CPU
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
AS_IF([test x"$HAVE_GNAT" = x"no"],[
AC_MSG_ERROR([No acceptable GNATMAKE found.])
])
+AM_CONDITIONAL(HAS_MP,test "$HAS_MP" = "yes")
+
RTEMS_CHECK_TOOL([GNATPREP],[gnatprep],[])
# FIXME: Enable building the examples which are known to be broken
@@ -43,13 +46,18 @@ AC_CONFIG_FILES([support/Makefile])
AC_CONFIG_FILES([
samples/Makefile
+samples/base_sp/Makefile
samples/hello/Makefile
samples/ticker/Makefile
-samples/base_sp/Makefile
+])
+
+if test "$HAS_MP" = "yes"; then
+AC_CONFIG_FILES([
samples/base_mp/Makefile
samples/base_mp/node1/Makefile
samples/base_mp/node2/Makefile
])
+fi
AC_CONFIG_FILES([
sptests/Makefile
@@ -112,6 +120,7 @@ tmtests/tmck/Makefile
tmtests/tmoverhd/Makefile
])
+if test "$HAS_MP" = "yes"; then
AC_CONFIG_FILES([
mptests/Makefile
mptests/mp01/Makefile
@@ -131,5 +140,6 @@ mptests/mp01/node2/Makefile
#mptests/mp12/Makefile
#mptests/mp13/Makefile
#mptests/mp14/Makefile
+fi
AC_OUTPUT