summaryrefslogtreecommitdiffstats
path: root/c/src/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-09 05:01:03 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-09 05:01:03 +0000
commitf0d7515908ea861f493003bd84432ffae680b707 (patch)
treeaff5c69509214a57e00bf31e19f3656da32d9b3b /c/src/Makefile.am
parent2002-08-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f0d7515908ea861f493003bd84432ffae680b707.tar.bz2
2002-08-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Create make/@RTEMS_BSP@.cache. Handle make/custom/*.cfgs. Create make/custom/default.cfg. * configure.ac: Add creation of make/custon/*.cfg. Create make/${RTEMS_BSP}.cache. Read make/${RTEMS_BSP}.cache
Diffstat (limited to 'c/src/Makefile.am')
-rw-r--r--c/src/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/c/src/Makefile.am b/c/src/Makefile.am
index 3f49d3f9b1..98b075e424 100644
--- a/c/src/Makefile.am
+++ b/c/src/Makefile.am
@@ -9,5 +9,26 @@ SUBDIRS = @exec@ @subdirs@
clean-local:
$(RM) -r $(PROJECT_RELEASE)
+make/@RTEMS_BSP@.cache: make/bsp.mak @CUSTOM_CFG_FILES@
+ $(RM) make/@RTEMS_BSP@.cache
+ $(MAKE) -f ${srcdir}/make/bsp.mak \
+ RTEMS_BSP=@RTEMS_BSP@ RTEMS_ROOT=. \
+ make/@RTEMS_BSP@.cache
+
+noinst_DATA = make/@RTEMS_BSP@.cache
+DISTCLEANFILES = make/@RTEMS_BSP@.cache
+
+rtems_make_customdir = $(rtems_makedir)/custom
+rtems_make_custom_DATA = @CUSTOM_CFG_FILES@
+
+make/custom/default.cfg: $(srcdir)/make/custom/default.cfg.in
+ cp $< $@
+
+make/custom/%.cfg: $(srcdir)/$(cfg_dir)/custom/%.cfg
+ cp $< $@
+
+noinst_DATA += make/custom/default.cfg
+DISTCLEANFILES += make/custom/default.cfg
+
include $(top_srcdir)/../../automake/subdirs.am
include $(top_srcdir)/../../automake/host.am