summaryrefslogtreecommitdiffstats
path: root/c/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-11 19:07:37 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-11 19:07:37 +0000
commit66387986497d71e9ff8bc71b91ba3e4f54c97264 (patch)
tree660ca3c251c4a0e12c897f2fef43b3eb6adf08a8 /c/configure.in
parent2001-10-11 Alexandra Kossovsky <sasha@oktet.ru> (diff)
downloadrtems-66387986497d71e9ff8bc71b91ba3e4f54c97264.tar.bz2
2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* .cvsignore: Add autom4te.cache for autoconf > 2.52. * configure.in: Remove. * configure.ac: New file, generated from configure.in by autoupdate.
Diffstat (limited to 'c/configure.in')
-rw-r--r--c/configure.in105
1 files changed, 0 insertions, 105 deletions
diff --git a/c/configure.in b/c/configure.in
deleted file mode 100644
index 9d9ae64b55..0000000000
--- a/c/configure.in
+++ /dev/null
@@ -1,105 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-dnl
-dnl $Id$
-
-AC_PREREQ(2.13)
-AC_INIT(src)
-RTEMS_TOP(..)
-AC_CONFIG_AUX_DIR(..)
-
-RTEMS_CANONICAL_TARGET_CPU
-
-AM_INIT_AUTOMAKE(rtems-c,$RTEMS_VERSION,no)
-AM_MAINTAINER_MODE
-
-dnl These options are used within this file.
-RTEMS_ENABLE_BARE
-RTEMS_ENABLE_RTEMSBSP(rtems_bsp)
-
-RTEMS_CHECK_CPU
-RTEMS_CANONICAL_HOST
-
-if test -z "$rtems_bsp"; then
- RTEMS_CHECK_BSPS(rtems_bsp)
-fi
-
-for i in $rtems_bsp; do
-
- # make sure there is a make/custom file for the bsp
- RTEMS_CHECK_CUSTOM_BSP(i)
-
- RTEMS_BSP_ALIAS($i,bspdir)
-
- # Is there code where there should be for this BSP?
- # The bare bsp is a special case as it is not under the RTEMS_CPU path
- case $bspdir in
- bare)
- bspcpudir=
- ;;
- *)
- bspcpudir=$RTEMS_CPU/
- ;;
- esac
-
- if test -d "$srcdir/$RTEMS_TOPdir/c/src/lib/libbsp/$bspcpudir$bspdir"; then
- RTEMS_BSP_LIST="$RTEMS_BSP_LIST $i"
- else
- AC_MSG_ERROR([unable to find libbsp directory ($bspdir) for $i])
- fi
-done
-
-#
-# Compose the configuration arguments to be passed to c/src/configure
-#
-##
-## Partially borrowed from autoconf-2.13
-##
-
-## Adjust paths
-_RTEMS_ADJUST_SRCDIR([rtems_bsp_configure],[src])
-rtems_bsp_configure="$rtems_bsp_configure/configure"
-
-## Remove --cache-file, --srcdir and --enable-rtemsbsp arguments
-## so they do not pile up
- rtems_bsp_configure_args=
- for ac_arg in $ac_configure_args; do
- if test -n "$ac_prev"; then
- ac_prev=
- continue
- fi
- case "$ac_arg" in
- -cache-file | --cache-file | --cache-fil | --cache-fi \
- | --cache-f | --cache- | --cache | --cach | --cac | --ca | --c)
- ac_prev=cache_file ;;
- -cache-file=* | --cache-file=* | --cache-fil=* | --cache-fi=* \
- | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
- ;;
- -srcdir | --srcdir | --srcdi | --srcd | --src | --sr)
- ac_prev=srcdir ;;
- -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
- ;;
- -enable-rtemsbsp=* | --enable-rtemsbsp=*) ;;
- -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
- ;;
- *) rtems_bsp_configure_args="$rtems_bsp_configure_args $ac_arg" ;;
- esac
- done
-
-rtems_bsp_configure="$rtems_bsp_configure $rtems_bsp_configure_args"
-AC_SUBST(rtems_bsp_configure)
-
-AC_SUBST(RTEMS_BSP_LIST)
-
-AC_CONFIG_SUBDIRS(make)
-
-# Explicitly list all Makefiles here
-AC_OUTPUT(
-Makefile
-)
-
-echo
-echo target architecture: $target_cpu.
-echo available BSPs: $rtems_bsp.
-echo \'${MAKE} all\' will build the following BSPs: $RTEMS_BSP_LIST.
-echo other BSPs can be built with \'${MAKE} RTEMS_BSP=\"bsp1 bsp2 ...\"\'
-echo