summaryrefslogtreecommitdiffstats
path: root/bootstrap
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-10-09 17:23:52 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-10-09 17:23:52 +0000
commit58fd5ab6b860e3d3e34a68a7d5b89abc3b44aab5 (patch)
treeb0312ab712efb4e5a2ef2ae567e883803d73a90a /bootstrap
parent4bf6f90d4b39191cf9b3a2e381f4d51d83e0767c (diff)
downloadrtems-58fd5ab6b860e3d3e34a68a7d5b89abc3b44aab5.tar.bz2
2002-10-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* bootstrap: Add autoconf/automake version checks by popular demand. [FWIW: I dislike this.]
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap30
1 files changed, 30 insertions, 0 deletions
diff --git a/bootstrap b/bootstrap
index 4af89886af..f0d34a3240 100755
--- a/bootstrap
+++ b/bootstrap
@@ -12,6 +12,9 @@
# to be run from the toplevel directory of RTEMS'
# source tree
+AUTOCONF_VERS=2.52
+AUTOMAKE_VERS=1.6.[123]
+
progname=`basename $0`
top_srcdir=`dirname $0`
@@ -61,7 +64,34 @@ done
case $mode in
generate)
+ AUTOCONF=${AUTOCONF-`which autoconf`}
+ if test -z "$AUTOCONF"; then
+ echo "You must have autoconf installed to run $program"
+ fi
+ AUTOCONF_VER=`$AUTOCONF --version 2>/dev/null`
+ if test -z "`echo $AUTOCONF_VER | grep \" $AUTOCONF_VERS\"`"; then
+cat << EOF
+RTEMS requires autoconf version $AUTOCONF_VERS.
+
+You are trying to use $AUTOCONF which does not seem to be sufficient
+EOF
+ exit 1
+ fi
+
+ AUTOMAKE=${AUTOMAKE-`which automake`}
+ if test -z "$AUTOMAKE"; then
+ echo "You must have automake installed to run $program"
+ fi
+ AUTOMAKE_VER=`$AUTOMAKE --version 2>/dev/null`
+ if test -z "`echo $AUTOMAKE_VER | grep \" $AUTOMAKE_VERS\"`"; then
+cat << EOF
+RTEMS requires automake version $AUTOMAKE_VERS.
+You are trying to use $AUTOMAKE which does not seem to be sufficient
+EOF
+ exit 1
+ fi
+
case $top_srcdir in
/* ) aclocal_dir=$top_srcdir
;;