summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/shared/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-05-14 09:23:26 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-05-14 09:52:02 -0500
commit156cb91355da8cb6255b0a0f754bd561cc7f03b0 (patch)
tree0e59a7161019216278fdd23015cf3b09e0a69069 /schedsim/shell/shared/Makefile.am
parentrtems/Makefile.am: Add task get and set affinity (diff)
downloadrtems-schedsim-156cb91355da8cb6255b0a0f754bd561cc7f03b0.tar.bz2
shell/shared: Add task get/set affinity
Diffstat (limited to 'schedsim/shell/shared/Makefile.am')
-rw-r--r--schedsim/shell/shared/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/schedsim/shell/shared/Makefile.am b/schedsim/shell/shared/Makefile.am
index 5b80e65..85b58af 100644
--- a/schedsim/shell/shared/Makefile.am
+++ b/schedsim/shell/shared/Makefile.am
@@ -49,6 +49,10 @@ libschedsim_a_SOURCES += main_taskwakeafter.c
libschedsim_a_SOURCES += schedsim_disable_dispatch.c
libschedsim_a_SOURCES += shell_cmdset.c
libschedsim_a_SOURCES += shell_makeargs.c
+if HAS_SMP
+libschedsim_a_SOURCES += main_taskgetaffinity.c
+libschedsim_a_SOURCES += main_tasksetaffinity.c
+endif
schedsim_shell_includedir = $(includedir)/schedsim
schedsim_newlib_includedir = $(includedir)/schedsim/newlib