summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/schedsim_priority/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-05-17 19:31:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-05-17 19:31:08 +0000
commit9077d3c2e4eeac466871dfc4a46e87b52012697f (patch)
tree88a39cf9a2565223d06cdad24c7f1240951d3602 /schedsim/shell/schedsim_priority/Makefile.am
parent2011-04-25 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-schedsim-9077d3c2e4eeac466871dfc4a46e87b52012697f.tar.bz2
2011-05-17 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am: Merge and update code. Simulators for Deterministic Priority and SMP Simple Schedulers now work. * ChangeLog, smp_stub.c, scenarios/script01.expected, scenarios/script01.output, scenarios/script01.scen, scenarios/script02.expected, scenarios/script02.output, scenarios/script02.scen, scenarios/script03.expected, scenarios/script03.output, scenarios/script03.scen, scenarios/script04.expected, scenarios/script04.output, scenarios/script04.scen, scenarios/script05.expected, scenarios/script05.output, scenarios/script05.scen, scenarios/script06.expected, scenarios/script06.output, scenarios/script06.scen: New files. * scenarios/script01, scenarios/script02, scenarios/script03, scenarios/script04, scenarios/script05, scenarios/script06: Removed.
Diffstat (limited to 'schedsim/shell/schedsim_priority/Makefile.am')
-rw-r--r--schedsim/shell/schedsim_priority/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/schedsim/shell/schedsim_priority/Makefile.am b/schedsim/shell/schedsim_priority/Makefile.am
index edd2e62..e616e37 100644
--- a/schedsim/shell/schedsim_priority/Makefile.am
+++ b/schedsim/shell/schedsim_priority/Makefile.am
@@ -6,8 +6,12 @@ bin_PROGRAMS = schedsim
schedsim_SOURCES = config.c \
schedsim.cc wrap_thread_dispatch.c printheir_executing.c
+if HAS_SMP
+schedsim_SOURCES += smp_stub.c
+endif
cpukitdir=@rtems_srcdir@/cpukit
-schedsim_CPPFLAGS = -I$(srcdir)/sched_cpu
+schedsim_CPPFLAGS = -I$(top_builddir)/score/include
+schedsim_CPPFLAGS += -I$(srcdir)/sched_cpu
schedsim_CPPFLAGS += -I$(srcdir)/../../rtems
schedsim_CPPFLAGS += -I$(cpukitdir)/include
schedsim_CPPFLAGS += -I$(cpukitdir)/score/include