summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/schedsim_priority/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2013-12-13 11:01:48 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-04-28 11:33:52 -0500
commit726b27c5bf4b2f4200953950b985b6e0fb7ce20f (patch)
tree6ae666752f68e3171dd8966bcca4431629369ba0 /schedsim/shell/schedsim_priority/Makefile.am
parent.configure.swp: Junk file removed from git (diff)
downloadrtems-schedsim-726b27c5bf4b2f4200953950b985b6e0fb7ce20f.tar.bz2
schedsim: Update to latest RTEMS. Works Uniprocessor
Diffstat (limited to 'schedsim/shell/schedsim_priority/Makefile.am')
-rw-r--r--schedsim/shell/schedsim_priority/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/schedsim/shell/schedsim_priority/Makefile.am b/schedsim/shell/schedsim_priority/Makefile.am
index 32febc6..378aea2 100644
--- a/schedsim/shell/schedsim_priority/Makefile.am
+++ b/schedsim/shell/schedsim_priority/Makefile.am
@@ -26,7 +26,16 @@ schedsim_priority_CPPFLAGS += -I$(cpukitdir)/posix/include
schedsim_priority_CPPFLAGS += -I$(cpukitdir)/posix/inline
endif
-schedsim_priority_LDFLAGS =-Wl,--wrap=_Thread_Dispatch
+## Ensure all linker provided symbols are available
+schedsim_priority_LDFLAGS =
+schedsim_priority_LDFLAGS += -Wl,--defsym=_TLS_Data_begin=0
+schedsim_priority_LDFLAGS += -Wl,--defsym=_TLS_BSS_end=0
+schedsim_priority_LDFLAGS += -Wl,--defsym=_TLS_Alignment=4
+
+## Wrap _Thread_Dispatch so we can see context switches
+schedsim_priority_LDFLAGS += -Wl,--wrap=_Thread_Dispatch
+
+## Link in all support libraries
## schedsim_priorityLDADD +=-Wl,--start-group
schedsim_priority_LDADD = ../shared/libschedsim.a
schedsim_priority_LDADD += ../../rtems/librtems.a