summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-05-17 19:31:16 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-05-17 19:31:16 +0000
commitac6e5c757df45281dbd9f0ba46d75075d0ddef70 (patch)
treecd510ffc474830f0a82fbcbd53cbb9f1a8c67705 /schedsim/shell/Makefile.am
parent2011-05-17 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-schedsim-ac6e5c757df45281dbd9f0ba46d75075d0ddef70.tar.bz2
2011-05-17 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am: Merge and update code. Simulators for Deterministic Priority and SMP Simple Schedulers now work. * run_scenarios: New file.
Diffstat (limited to 'schedsim/shell/Makefile.am')
-rw-r--r--schedsim/shell/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/schedsim/shell/Makefile.am b/schedsim/shell/Makefile.am
index 9cd86f5..30b2456 100644
--- a/schedsim/shell/Makefile.am
+++ b/schedsim/shell/Makefile.am
@@ -4,9 +4,13 @@
ACLOCAL_AMFLAGS = -I ./../aclocal
-SUBDIRS = shared schedsim_priority
-
+SUBDIRS = shared schedsim_priority
DIST_SUBDIRS = shared schedsim_priority
+if HAS_SMP
+SUBDIRS += schedsim_smpsimple
+DIST_SUBDIRS += schedsim_smpsimple
+endif
+
include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/host.am