summaryrefslogtreecommitdiffstats
path: root/schedsim/shell/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2014-06-17 12:03:25 -0500
committerJennifer Averett <jennifer.averett@oarcorp.com>2014-06-17 12:03:25 -0500
commit6f48a61527f4fad2244d7d8bfa67795d042c7fef (patch)
treeecda4c9713a6fbaf0d1af8dbce438f8cd67b23d9 /schedsim/shell/Makefile.am
parentrtems: Add _Thread_Yield support. (diff)
downloadrtems-schedsim-6f48a61527f4fad2244d7d8bfa67795d042c7fef.tar.bz2
Add remainder of schedulers and cluster scheduler support.
Diffstat (limited to 'schedsim/shell/Makefile.am')
-rw-r--r--schedsim/shell/Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/schedsim/shell/Makefile.am b/schedsim/shell/Makefile.am
index d920e37..46a8ddd 100644
--- a/schedsim/shell/Makefile.am
+++ b/schedsim/shell/Makefile.am
@@ -1,15 +1,30 @@
ACLOCAL_AMFLAGS = -I ./../aclocal
-SUBDIRS = shared schedsim_priority schedsim_simple
-DIST_SUBDIRS = shared schedsim_priority schedsim_simple
+SUBDIRS = shared
+SUBDIRS += schedsim_priority
+SUBDIRS += schedsim_simple
+SUBDIRS += schedsim_cbs
+SUBDIRS += schedsim_edf
+
+DIST_SUBDIRS = shared
+DIST_SUBDIRS += shared
+DIST_SUBDIRS += schedsim_priority
+DIST_SUBDIRS += schedsim_simple
+DIST_SUBDIRS += schedsim_cbs
+DIST_SUBDIRS += schedsim_edf
if HAS_SMP
SUBDIRS += schedsim_smpsimple
-DIST_SUBDIRS += schedsim_smpsimple
SUBDIRS += schedsim_smppriority
-DIST_SUBDIRS += schedsim_smppriority
SUBDIRS += schedsim_smppriority_affinity
+SUBDIRS += schedsim_cluster01
+SUBDIRS += schedsim_cluster02
+
+DIST_SUBDIRS += schedsim_smpsimple
+DIST_SUBDIRS += schedsim_smppriority
DIST_SUBDIRS += schedsim_smppriority_affinity
+DIST_SUBDIRS += schedsim_cluster01
+DIST_SUBDIRS += schedsim_cluster02
endif
include $(top_srcdir)/../automake/subdirs.am