summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-25 15:53:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-25 15:53:10 +0000
commitabb18dc4eb102a15a67990ad1b0c515176808a5b (patch)
treeaebe2dc318e747b42939afe13e9b506ddc282d66 /Makefile.am
downloadrtems-schedsim-abb18dc4eb102a15a67990ad1b0c515176808a5b.tar.bz2
Initial import.initialbase
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f3768d7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,41 @@
+#
+# top level directory for RTEMS build tree
+#
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I aclocal
+
+SUBDIRS = $(build_SUBDIRS) $(host_SUBDIRS) $(target_SUBDIRS)
+DIST_SUBDIRS = $(SUBDIRS)
+
+EXTRA_DIST = SUPPORT VERSION LICENSE
+EXTRA_DIST += ampolish3
+
+dist-hook:
+ @files=`(cd $(srcdir); find doc cpukit c testsuites tools \
+ -name configure.ac -print | sed 's,/configure.ac,,' | sort)`; \
+ for i in $$files; do \
+ if test -f $(distdir)/$$i/configure.ac; then : ; \
+ else \
+ d=`dirname $(distdir)/$$i`; \
+ $(MKDIR_P) $$d;\
+ echo "cp -pR $(srcdir)/$$i $(distdir)/$$i"; \
+ cp -pR $(srcdir)/$$i $(distdir)/$$i; \
+ fi; \
+ done
+ rm -rf `find $(distdir) -name 'autom4te*'`
+ rm -rf `find $(distdir) -name CVS`
+ rm -f `find $(distdir) \( -name .cvsignore \
+ -o -name config.status \
+ -o -name config.log \)`
+ rm -f `find $(distdir) \( -name '*.bak' \
+ -o -name 'changes' -o -name 'diff' -o -name 'tmp' -o -name 'log' \
+ -o -name '*~' -o -name '.*~' -o -name '.#*' \)`
+ find $(distdir) -name '*.in' -print | while read a; do \
+ f=`echo $$a | sed 's,\.in$$,,'`; \
+ if test -f $$f; then echo "rm $$f"; rm $$f; fi; done
+
+include $(top_srcdir)/automake/subdirs.am
+include $(top_srcdir)/automake/host.am