summaryrefslogtreecommitdiffstats
path: root/ipsec-tools/rpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ipsec-tools/rpm/Makefile.am')
-rw-r--r--ipsec-tools/rpm/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/ipsec-tools/rpm/Makefile.am b/ipsec-tools/rpm/Makefile.am
new file mode 100644
index 00000000..b01b2ef3
--- /dev/null
+++ b/ipsec-tools/rpm/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = suse
+
+EXTRA_DIST = \
+ ipsec-tools.spec.in
+
+all-local: ipsec-tools.spec
+
+## We borrow guile's convention and use @-...-@ as the substitution
+## brackets here, instead of the usual @...@. This prevents autoconf
+## from substituting the values directly into the left-hand sides of
+## the sed substitutions. *sigh*
+ipsec-tools.spec: ipsec-tools.spec.in Makefile
+ rm -f $@.tmp
+ sed < $< > $@.tmp \
+ -e 's:@-VERSION-@:${VERSION}:'
+ mv $@.tmp $@
+
+CLEANFILES = ipsec-tools.spec