summaryrefslogtreecommitdiffstats
path: root/ncurses-5.3/sysdeps/unix/sysv/linux
diff options
context:
space:
mode:
Diffstat (limited to 'ncurses-5.3/sysdeps/unix/sysv/linux')
-rw-r--r--ncurses-5.3/sysdeps/unix/sysv/linux/Makefile10
-rwxr-xr-xncurses-5.3/sysdeps/unix/sysv/linux/alpha/configure2
-rwxr-xr-xncurses-5.3/sysdeps/unix/sysv/linux/configure407
-rw-r--r--ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sed100
-rwxr-xr-xncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sh37
-rwxr-xr-xncurses-5.3/sysdeps/unix/sysv/linux/run_tic.sh143
6 files changed, 699 insertions, 0 deletions
diff --git a/ncurses-5.3/sysdeps/unix/sysv/linux/Makefile b/ncurses-5.3/sysdeps/unix/sysv/linux/Makefile
new file mode 100644
index 0000000..9489c19
--- /dev/null
+++ b/ncurses-5.3/sysdeps/unix/sysv/linux/Makefile
@@ -0,0 +1,10 @@
+ifeq ($(subdir),ncurses)
+
+CPPFLAGS += -DNDEBUG -DHAVE_CONFIG_H
+
+edit_man-sed = sysdeps/unix/sysv/linux/edit_man.sed
+edit_man-sh = sysdeps/unix/sysv/linux/edit_man.sh
+
+run_tic-sh = sysdeps/unix/sysv/linux/run_tic.sh
+
+endif
diff --git a/ncurses-5.3/sysdeps/unix/sysv/linux/alpha/configure b/ncurses-5.3/sysdeps/unix/sysv/linux/alpha/configure
new file mode 100755
index 0000000..6fa2519
--- /dev/null
+++ b/ncurses-5.3/sysdeps/unix/sysv/linux/alpha/configure
@@ -0,0 +1,2 @@
+# Alpha uses long as bool.
+nc_cv_type_of_bool=long
diff --git a/ncurses-5.3/sysdeps/unix/sysv/linux/configure b/ncurses-5.3/sysdeps/unix/sysv/linux/configure
new file mode 100755
index 0000000..e83e080
--- /dev/null
+++ b/ncurses-5.3/sysdeps/unix/sysv/linux/configure
@@ -0,0 +1,407 @@
+# Local configure fragment for ncurses/sysdeps/unix/sysv/linux.
+
+nc_given_srcdir=${srcdir}/ncurses
+
+NCURSES_MAJOR="`egrep '^NCURSES_MAJOR[ ]*=' $nc_given_srcdir/dist.mk | sed -e 's/^[^0-9]*//'`"
+NCURSES_MINOR="`egrep '^NCURSES_MINOR[ ]*=' $nc_given_srcdir/dist.mk | sed -e 's/^[^0-9]*//'`"
+NCURSES_PATCH="`egrep '^NCURSES_PATCH[ ]*=' $nc_given_srcdir/dist.mk | sed -e 's/^[^0-9]*//'`"
+cf_cv_abi_version=${NCURSES_MAJOR}
+cf_cv_rel_version=${NCURSES_MAJOR}.${NCURSES_MINOR}
+
+# Default to char
+if [ x${cf_cv_type_of_bool} = x ]
+then
+ cf_cv_type_of_bool=char
+fi
+
+rm -f ncurses/MKterm.h.awk \
+ ncurses/codes.c \
+ ncurses/comp_captab.c \
+ ncurses/confdefs.h \
+ ncurses/config.log \
+ ncurses/curses.h \
+ ncurses/expanded.c \
+ ncurses/fallback.c \
+ ncurses/hashsize.h \
+ ncurses/init_keytry.h \
+ ncurses/lib_gen.c \
+ ncurses/lib_keyname.c \
+ ncurses/names.c \
+ ncurses/ncurses_cfg.h \
+ ncurses/nomacros.h \
+ ncurses/parametrized.h \
+ ncurses/term.h \
+ ncurses/termcap.h \
+ ncurses/terminfo.5 \
+ ncurses/termsort.c \
+ ncurses/unctrl.c \
+ ncurses/unctrl.h
+
+# Protect against being on the right side of a sed subst in config.status.
+sed 's/%@/@@/; s/@%/@@/; s/%g$/@g/; /@g$/s/[\\&%]/\\&/g;
+ s/@@/%@/; s/@@/@%/; s/@g$/%g/' > conftest.subs <<EOF
+
+
+s%@DEFS@%-DHAVE_CONFIG_H%g
+s%@NCURSES_MAJOR@%$NCURSES_MAJOR%g
+s%@NCURSES_MINOR@%$NCURSES_MINOR%g
+s%@NCURSES_PATCH@%$NCURSES_PATCH%g
+s%@NCURSES_CONST@%%g
+s%@NCURSES_XNAMES@%1%g
+s%@OSPEED_TYPE@%speed_t%g
+s%@OSPEED_INCLUDES@%#include <termios.h>%g
+s%@cf_cv_rel_version@%$cf_cv_rel_version%g
+s%@cf_cv_abi_version@%$cf_cv_abi_version%g
+s%@cf_cv_builtin_bool@%1%g
+s%@cf_cv_type_of_bool@%$cf_cv_type_of_bool%g
+s%@cf_cv_shift_limit@%32%g
+s%@cf_cv_widec_shift@%8%g
+s%@cf_cv_typeof_chtype@%long%g
+s%@cf_cv_1UL@%1UL%g
+s%@cf_cv_cc_bool_type@%0%g
+
+EOF
+
+# Split the substitutions into bite-sized pieces for seds with
+# small command number limits, like on Digital OSF/1 and HP-UX.
+nc_max_sed_cmds=90 # Maximum number of lines to put in a sed script.
+nc_file=1 # Number of current file.
+nc_beg=1 # First line for current file.
+nc_end=$nc_max_sed_cmds # Line after last line for current file.
+nc_more_lines=:
+nc_sed_cmds=""
+while $nc_more_lines; do
+ if test $nc_beg -gt 1; then
+ sed "1,${nc_beg}d; ${nc_end}q" conftest.subs > conftest.s$nc_file
+ else
+ sed "${nc_end}q" conftest.subs > conftest.s$nc_file
+ fi
+ if test ! -s conftest.s$nc_file; then
+ nc_more_lines=false
+ rm -f conftest.s$nc_file
+ else
+ if test -z "$nc_sed_cmds"; then
+ nc_sed_cmds="sed -f conftest.s$nc_file"
+ else
+ nc_sed_cmds="$nc_sed_cmds | sed -f conftest.s$nc_file"
+ fi
+ nc_file=`expr $nc_file + 1`
+ nc_beg=$nc_end
+ nc_end=`expr $nc_end + $nc_max_sed_cmds`
+ fi
+done
+if test -z "$nc_sed_cmds"; then
+ nc_sed_cmds=cat
+fi
+
+NC_CONFIG_FILES=${NC_CONFIG_FILES-"ncurses/MKterm.h.awk ncurses/curses.h ncurses/termcap.h ncurses/unctrl.h"}
+for nc_file in .. $NC_CONFIG_FILES; do if test "x$nc_file" != x..; then
+ # Support "outfile[:infile[:infile...]]", defaulting infile="outfile.in".
+ case "$nc_file" in
+ *:*) nc_file_in=`echo "$nc_file"|sed 's%[^:]*:%%'`
+ nc_file=`echo "$nc_file"|sed 's%:.*%%'` ;;
+ *) nc_file_in=`echo "${nc_file}" | sed 's%ncurses%include%'`.in ;;
+ esac
+
+ # Adjust a relative srcdir, top_srcdir, and INSTALL for subdirectories.
+
+ # Remove last slash and all that follows it. Not all systems have dirname.
+ nc_dir=`echo $nc_file|sed 's%/[^/][^/]*$%%'`
+ if test "$nc_dir" != "$nc_file" && test "$nc_dir" != .; then
+ # The file is in a subdirectory.
+ test ! -d "$nc_dir" && mkdir "$nc_dir"
+ nc_dir_suffix="/`echo $nc_dir|sed 's%^\./%%'`"
+ # A "../" for each directory in $nc_dir_suffix.
+ nc_dots=`echo $nc_dir_suffix|sed 's%/[^/]*%../%g'`
+ else
+ nc_dir_suffix= nc_dots=
+ fi
+
+ case "$nc_given_srcdir" in
+ .) nc_srcdir=.
+ if test -z "$nc_dots"; then nc_top_srcdir=.
+ else nc_top_srcdir=`echo $nc_dots|sed 's%/$%%'`; fi ;;
+ /*) nc_srcdir="$nc_given_srcdir$nc_dir_suffix"; nc_top_srcdir="$nc_given_srcdir" ;;
+ *) # Relative path.
+ nc_srcdir="$nc_dots$nc_given_srcdir$nc_dir_suffix"
+ nc_top_srcdir="$nc_dots$nc_given_srcdir" ;;
+ esac
+
+ case "$ac_given_INSTALL" in
+ [/$]*) NC_INSTALL="$ac_given_INSTALL" ;;
+ *) NC_INSTALL="$nc_dots$ac_given_INSTALL" ;;
+ esac
+
+ echo creating "$nc_file"
+ rm -f "$nc_file"
+ configure_input="Generated automatically from `echo $nc_file_in|sed 's%.*/%%'` by configure."
+ case "$nc_file" in
+ *Makefile*) nc_comsub="1i\\
+# $configure_input" ;;
+ *) nc_comsub= ;;
+ esac
+
+ nc_file_inputs=`echo $nc_file_in|sed -e "s%^%$nc_given_srcdir/%" -e "s%:% $nc_given_srcdir/%g"`
+ sed -e "$nc_comsub
+s%@configure_input@%$configure_input%g
+s%@nc_srcdir@%$nc_srcdir%g
+s%@nc_top_srcdir@%$nc_top_srcdir%g
+s%@INSTALL@%$NC_INSTALL%g
+" $nc_file_inputs | (eval "$nc_sed_cmds") > $nc_file
+fi; done
+rm -f conftest.s*
+
+# These sed commands are passed to sed as "A NAME B NAME C VALUE D", where
+# NAME is the cpp macro being defined and VALUE is the value it is being given.
+#
+# nc_d sets the value in "#define NAME VALUE" lines.
+nc_dA='s%^\([ ]*\)#\([ ]*define[ ][ ]*\)'
+nc_dB='\([ ][ ]*\)[^ ]*%\1#\2'
+nc_dC='\3'
+nc_dD='%g'
+# nc_u turns "#undef NAME" with trailing blanks into "#define NAME VALUE".
+nc_uA='s%^\([ ]*\)#\([ ]*\)undef\([ ][ ]*\)'
+nc_uB='\([ ]\)%\1#\2define\3'
+nc_uC=' '
+nc_uD='\4%g'
+# nc_e turns "#undef NAME" without trailing blanks into "#define NAME VALUE".
+nc_eA='s%^\([ ]*\)#\([ ]*\)undef\([ ][ ]*\)'
+nc_eB='$%\1#\2define\3'
+nc_eC=' '
+nc_eD='%g'
+
+NC_CONFIG_HEADERS="ncurses/ncurses_cfg.h:include/ncurses_cfg.hin"
+for nc_file in .. $NC_CONFIG_HEADERS; do if test "x$nc_file" != x..; then
+ # Support "outfile[:infile[:infile...]]", defaulting infile="outfile.in".
+ case "$nc_file" in
+ *:*) nc_file_in=`echo "$nc_file"|sed 's%[^:]*:%%'`
+ nc_file=`echo "$nc_file"|sed 's%:.*%%'` ;;
+ *) nc_file_in="${nc_file}.in" ;;
+ esac
+
+ echo creating $nc_file
+
+ rm -f conftest.frag conftest.in conftest.out
+ nc_file_inputs=`echo $nc_file_in|sed -e "s%^%$nc_given_srcdir/%" -e "s%:% $nc_given_srcdir/%g"`
+ cat $nc_file_inputs > conftest.in
+
+ rm -f conftest.frag
+ cat >> conftest.frag <<CEOF
+
+#define CC_HAS_INLINE_FUNCS 1
+#define GCC_NORETURN __attribute__((noreturn))
+#define GCC_PRINTF 1
+#define GCC_SCANF 1
+#define GCC_UNUSED __attribute__((unused))
+#define GOOD_SELECT 1
+#define HAVE_BUILTIN_H 1
+#define HAVE_DIRENT_H 1
+#define HAVE_ERRNO 1
+#define HAVE_FCNTL_H 1
+#define HAVE_FORM_H 1
+#define HAVE_GETOPT_H 1
+CEOF
+ cat >> conftest.frag <<CEOF
+#define HAVE_GETTIMEOFDAY 1
+#define HAVE_GETTTYNAM 1
+#define HAVE_ISASCII 1
+#define HAVE_LIBFORM 1
+#define HAVE_LIBMENU 1
+#define HAVE_LIBPANEL 1
+#define HAVE_LIMITS_H 1
+#define HAVE_LINK 1
+#define HAVE_LOCALE_H 1
+#define HAVE_LONG_FILE_NAMES 1
+#define HAVE_MEMCCPY 1
+#define HAVE_MENU_H 1
+#define HAVE_NANOSLEEP 1
+#define HAVE_NC_ALLOC_H 1
+CEOF
+ cat >> conftest.frag <<CEOF
+#define HAVE_PANEL_H 1
+#define HAVE_POLL 1
+#define HAVE_POLL_H 1
+#define HAVE_REGEX_H_FUNCS 1
+#define HAVE_REMOVE 1
+#define HAVE_SELECT 1
+#define HAVE_SETBUF 1
+#define HAVE_SETBUFFER 1
+#define HAVE_SETVBUF 1
+#define HAVE_SIGACTION 1
+#define HAVE_SIGVEC 1
+#define HAVE_SIZECHANGE 1
+CEOF
+ cat >> conftest.frag <<CEOF
+#define HAVE_STRDUP 1
+#define HAVE_SYMLINK 1
+#define HAVE_SYS_IOCTL_H 1
+#define HAVE_SYS_PARAM_H 1
+#define HAVE_SYS_SELECT_H 1
+#define HAVE_SYS_TIMES_H 1
+#define HAVE_SYS_TIME_H 1
+#define HAVE_SYS_TIME_SELECT 1
+#define HAVE_TCGETATTR 1
+#define HAVE_TERMIOS_H 1
+#define HAVE_TERMIO_H 1
+#define HAVE_TIMES 1
+#define HAVE_TTYENT_H 1
+CEOF
+ cat >> conftest.frag <<CEOF
+#define HAVE_TYPEINFO 1
+#define HAVE_UNISTD_H 1
+#define HAVE_VALUES_H 1
+#define HAVE_VFSCANF 1
+#define HAVE_VSNPRINTF 1
+#define HAVE_VSSCANF 1
+#define NCURSES_EXT_FUNCS 1
+#define NDEBUG 1
+#define PURE_TERMINFO 1
+#define RETSIGTYPE void
+#define STDC_HEADERS 1
+CEOF
+ cat >> conftest.frag <<CEOF
+#define SYSTEM_NAME "linux-gnu"
+#define TYPEOF_CHTYPE long
+#define USE_DATABASE 1
+#define USE_HASHMAP 1
+#define USE_LINKS 1
+#define NCURSES_NO_PADDING 1
+#define USE_SIGWINCH 1
+CEOF
+ cat >> conftest.edit <<CEOF
+/@DEFS@/r conftest.frag
+/@DEFS@/d
+CEOF
+sed -f conftest.edit conftest.in > conftest.out
+rm -f conftest.in
+mv conftest.out conftest.in
+rm -f conftest.edit conftest.frag
+
+ rm -f conftest.frag conftest.h
+ echo "/* $nc_file. Generated automatically by configure. */" > conftest.h
+ cat conftest.in >> conftest.h
+ rm -f conftest.in
+ if cmp -s $nc_file conftest.h 2>/dev/null; then
+ echo "$nc_file is unchanged"
+ rm -f conftest.h
+ else
+ # Remove last slash and all that follows it. Not all systems have dirname.
+ nc_dir=`echo $nc_file|sed 's%/[^/][^/]*$%%'`
+ if test "$nc_dir" != "$nc_file" && test "$nc_dir" != .; then
+ # The file is in a subdirectory.
+ test ! -d "$nc_dir" && mkdir "$nc_dir"
+ fi
+ rm -f $nc_file
+ mv conftest.h $nc_file
+ fi
+fi; done
+
+
+SYS_NAME=`uname -a`
+if test -z "$SYS_NAME"; then SYS_NAME=unknown;fi
+
+NC_AWK=awk
+BUILD_CC=${BUILD_CC-gcc}
+NC_CC="${BUILD_CC} -I${nc_given_srcdir}/ncurses -Incurses -I${nc_given_srcdir}/include"
+NC_CPP="${NC_CC} -E"
+CF_LIST_MODELS="normal"
+#WITH_ECHO="yes"
+#WITH_OVERWRITE="yes"
+nc_cxx_library="yes"
+cf_cv_systype="Linux"
+cf_cv_rel_version="4.2"
+cf_cv_abi_version="4"
+cf_cv_do_symlinks="yes"
+cf_cv_rm_so_locs="no"
+
+
+rm -f headers.sed headers.sh
+
+echo creating headers.sh
+cat >headers.sh <<NC_EOF
+#!/bin/sh
+# This shell script is generated by the 'configure' script. It is invoked in a
+# subdirectory of the build tree. It generates a sed-script in the parent
+# directory that is used to adjust includes for header files that reside in a
+# subdirectory of /usr/include, etc.
+PRG=""
+while test \$# != 3
+do
+PRG="\$PRG \$1"; shift
+done
+DST=\$1
+REF=\$2
+SRC=\$3
+echo installing \$SRC in \$DST
+case \$DST in
+/*/include/*)
+ TMP=\${TMPDIR-/tmp}/\`basename \$SRC\`
+ if test ! -f ../headers.sed ; then
+ END=\`basename \$DST\`
+ for i in \`cat \$REF/../*/headers |fgrep -v "#"\`
+ do
+ NAME=\`basename \$i\`
+ echo "s/<\$NAME>/<\$END\/\$NAME>/" >> ../headers.sed
+ done
+ fi
+ rm -f \$TMP
+ sed -f ../headers.sed \$SRC > \$TMP
+ eval \$PRG \$TMP \$DST
+ rm -f \$TMP
+ ;;
+*)
+ eval \$PRG \$SRC \$DST
+ ;;
+esac
+NC_EOF
+
+chmod 0755 headers.sh
+
+echo creating ncurses/term.h
+${NC_AWK} -f ncurses/MKterm.h.awk ${nc_given_srcdir}/include/Caps > ncurses/term.h
+sh ${nc_given_srcdir}/include/edit_cfg.sh ncurses/ncurses_cfg.h ncurses/term.h
+
+echo creating ncurses/hashsize.h
+sh ${nc_given_srcdir}/include/MKhashsize.sh ${nc_given_srcdir}/include/Caps > ncurses/hashsize.h
+
+echo creating ncurses/parametrized.h
+sh ${nc_given_srcdir}/include/MKparametrized.sh ${nc_given_srcdir}/include/Caps > ncurses/parametrized.h
+
+echo creating ncurses/termsort.c
+sh ${nc_given_srcdir}/progs/MKtermsort.sh "${NC_AWK}" ${nc_given_srcdir}/include/Caps > ncurses/termsort.c
+
+echo creating ncurses/fallback.c
+sh ${nc_given_srcdir}/ncurses/tinfo/MKfallback.sh > ncurses/fallback.c
+
+echo creating ncurses/lib_gen.c
+sh ${nc_given_srcdir}/ncurses/base/MKlib_gen.sh "${NC_CPP}" "${NC_AWK}" < ncurses/curses.h > ncurses/lib_gen.c
+
+echo creating ncurses/nomacros.h
+sh ${nc_given_srcdir}/ncurses/base/MKlib_gen.sh "${NC_CPP}" "${NC_AWK}" < ncurses/curses.h | fgrep undef > ncurses/nomacros.h
+
+echo creating ncurses/expanded.c
+sh ${nc_given_srcdir}/ncurses/tty/MKexpanded.sh "${NC_CPP}" >ncurses/expanded.c
+
+echo creating ncurses/comp_captab.c
+${NC_CC} -o make_hash -DMAIN_PROGRAM ${nc_given_srcdir}/ncurses/tinfo/comp_hash.c
+sh ${nc_given_srcdir}/ncurses/tinfo/MKcaptab.awk "${NC_AWK}" ${nc_given_srcdir}/include/Caps > ncurses/comp_captab.c
+rm -f make_hash
+
+echo creating ncurses/lib_keyname.c
+${NC_AWK} -f ${nc_given_srcdir}/ncurses/base/MKkeyname.awk ${nc_given_srcdir}/ncurses/tinfo/keys.list > ncurses/lib_keyname.c
+
+echo creating ncurses/names.c and ncurses/codes.c
+${NC_AWK} -f ${nc_given_srcdir}/ncurses/tinfo/MKnames.awk ${nc_given_srcdir}/include/Caps
+cat namehdr boolnames boolfnames numnames numfnames strnames strfnames nameftr >ncurses/names.c
+cat namehdr boolcodes numcodes strcodes codeftr > ncurses/codes.c
+rm -f namehdr nameftr codeftr boolnames boolfnames boolcodes numnames numfnames numcodes strnames strfnames strcodes
+
+echo creating ncurses/init_keytry.h
+${NC_CC} -o make_key ${nc_given_srcdir}/ncurses/tinfo/make_keys.c
+./make_key ${nc_given_srcdir}/ncurses/keys.list > ncurses/init_keytry.h
+rm -f make_key
+
+echo creating ncurses/unctrl.c
+echo | ${NC_AWK} -f ${nc_given_srcdir}/ncurses/base/MKunctrl.awk > ncurses/unctrl.c
+echo creating ncurses/terminfo.5
+sh ${nc_given_srcdir}/man/MKterminfo.sh ${nc_given_srcdir}/man/terminfo.head ${nc_given_srcdir}/include/Caps ${nc_given_srcdir}/man/terminfo.tail > ncurses/terminfo.5
diff --git a/ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sed b/ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sed
new file mode 100644
index 0000000..163eb7b
--- /dev/null
+++ b/ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sed
@@ -0,0 +1,100 @@
+s/captoinfo\.1m/captoinfo.1m/g
+s/clear\.1/clear.1m/g
+s/curs_addch\.3x/addch.3ncurses/g
+s/curs_addchstr\.3x/addchstr.3ncurses/g
+s/curs_addstr\.3x/addstr.3ncurses/g
+s/curs_attr\.3x/attr.3ncurses/g
+s/curs_beep\.3x/beep.3ncurses/g
+s/curs_bkgd\.3x/bkgd.3ncurses/g
+s/curs_border\.3x/border.3ncurses/g
+s/curs_clear\.3x/clear.3ncurses/g
+s/curs_color\.3x/color.3ncurses/g
+s/curs_delch\.3x/delch.3ncurses/g
+s/curs_deleteln\.3x/deleteln.3ncurses/g
+s/curs_getch\.3x/getch.3ncurses/g
+s/curs_getstr\.3x/getstr.3ncurses/g
+s/curs_getyx\.3x/getyx.3ncurses/g
+s/curs_inch\.3x/inch.3ncurses/g
+s/curs_inchstr\.3x/inchstr.3ncurses/g
+s/curs_initscr\.3x/initscr.3ncurses/g
+s/curs_inopts\.3x/inopts.3ncurses/g
+s/curs_insch\.3x/insch.3ncurses/g
+s/curs_insstr\.3x/insstr.3ncurses/g
+s/curs_instr\.3x/instr.3ncurses/g
+s/curs_kernel\.3x/kernel.3ncurses/g
+s/curs_mouse\.3x/mouse.3ncurses/g
+s/curs_move\.3x/move.3ncurses/g
+s/curs_outopts\.3x/outopts.3ncurses/g
+s/curs_overlay\.3x/overlay.3ncurses/g
+s/curs_pad\.3x/pad.3ncurses/g
+s/curs_print\.3x/print.3ncurses/g
+s/curs_printw\.3x/printw.3ncurses/g
+s/curs_refresh\.3x/refresh.3ncurses/g
+s/curs_scanw\.3x/scanw.3ncurses/g
+s/curs_scr_dmp\.3x/scr_dmp.3ncurses/g
+s/curs_scroll\.3x/scroll.3ncurses/g
+s/curs_slk\.3x/slk.3ncurses/g
+s/curs_termattrs\.3x/termattrs.3ncurses/g
+s/curs_termcap\.3x/termcap.3ncurses/g
+s/curs_terminfo\.3x/terminfo.3ncurses/g
+s/curs_touch\.3x/touch.3ncurses/g
+s/curs_util\.3x/util.3ncurses/g
+s/curs_window\.3x/window.3ncurses/g
+s/form\.3x/form.3form/g
+s/form_cursor\.3x/cursor.3form/g
+s/form_data\.3x/data.3form/g
+s/form_driver\.3x/driver.3form/g
+s/form_field\.3x/field.3form/g
+s/form_field_attributes\.3x/field_attributes.3form/g
+s/form_field_buffer\.3x/field_buffer.3form/g
+s/form_field_info\.3x/field_info.3form/g
+s/form_field_just\.3x/field_just.3form/g
+s/form_field_new\.3x/field_new.3form/g
+s/form_field_opts\.3x/field_opts.3form/g
+s/form_field_userptr\.3x/field_userptr.3form/g
+s/form_field_validation\.3x/field_validation.3form/g
+s/form_fieldtype\.3x/fieldtype.3form/g
+s/form_hook\.3x/hook.3form/g
+s/form_new\.3x/new.3form/g
+s/form_new_page\.3x/new_page.3form/g
+s/form_opts\.3x/opts.3form/g
+s/form_page\.3x/page.3form/g
+s/form_post\.3x/post.3form/g
+s/form_requestname\.3x/requestname.3form/g
+s/form_userptr\.3x/userptr.3form/g
+s/form_win\.3x/win.3form/g
+s/infocmp\.1m/infocmp.1m/g
+s/menu\.3x/menu.3menu/g
+s/menu_attribs\.3x/attribs.3menu/g
+s/menu_cursor\.3x/cursor.3menu/g
+s/menu_driver\.3x/driver.3menu/g
+s/menu_format\.3x/format.3menu/g
+s/menu_hook\.3x/hook.3menu/g
+s/menu_items\.3x/items.3menu/g
+s/menu_mark\.3x/mark.3menu/g
+s/menu_new\.3x/new.3menu/g
+s/menu_opts\.3x/opts.3menu/g
+s/menu_pattern\.3x/pattern.3menu/g
+s/menu_post\.3x/post.3menu/g
+s/menu_requestname\.3x/requestname.3menu/g
+s/menu_spacing\.3x/spacing.3menu/g
+s/menu_userptr\.3x/userptr.3menu/g
+s/menu_win\.3x/win.3menu/g
+s/mitem_current\.3x/menu_current.3menu/g
+s/mitem_name\.3x/menu_name.3menu/g
+s/mitem_new\.3x/menu_new.3menu/g
+s/mitem_opts\.3x/menu_opts.3menu/g
+s/mitem_userptr\.3x/menu_userptr.3menu/g
+s/mitem_value\.3x/menu_value.3menu/g
+s/mitem_visible\.3x/menu_visible.3menu/g
+s/ncurses\.3x/ncurses.3ncurses/g
+s/panel\.3x/panel.3curses/g
+s/resizeterm\.3x/resizeterm.3ncurses/g
+s/term\.5/term.5/g
+s/term\.7/term.7/g
+s/terminfo\.5/terminfo.5/g
+s/tic\.1m/tic.1m/g
+s/toe\.1m/toe.1m/g
+s/tput\.1/tput.1/g
+s/tset\.1/tset.1/g
+s/wresize\.3x/wresize.3ncurses/g
diff --git a/ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sh b/ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sh
new file mode 100755
index 0000000..558fff8
--- /dev/null
+++ b/ncurses-5.3/sysdeps/unix/sysv/linux/edit_man.sh
@@ -0,0 +1,37 @@
+#!/bin/sh
+# this script is generated by the configure-script
+prefix=$1
+shift
+mandir=$1
+shift
+edit_man_sed=$1
+shift
+
+datadir="${prefix}/share"
+MKDIRS="mkinstalldirs"
+INSTALL="/usr/bin/install -c"
+INSTALL_DATA="${INSTALL} -m 644"
+TMP=${TMPDIR-/tmp}/man$$
+trap "rm -f $TMP" 0 1 2 5 15
+
+for i in $*
+do
+case $i in
+*.[0-9]*)
+ section=`expr "$i" : '.*\.\([0-9]\)[xm]*'`;
+ if [ ! -d $mandir/man${section} ]; then
+ $MKDIRS $mandir/man$section
+ fi
+ source=`basename $i`
+ target=`grep "^$source" man/man_db.renames | awk '{print $2}'`
+ if test -z "$target" ; then
+ echo '? missing rename for '$source
+ target="$source"
+ fi
+ target="$mandir/man$section/$target"
+ sed -e 's,@DATADIR@,$datadir,' < $i | sed -f ${edit_man_sed} >$TMP
+ echo installing $target
+ $INSTALL_DATA $TMP $target
+ ;;
+esac
+done
diff --git a/ncurses-5.3/sysdeps/unix/sysv/linux/run_tic.sh b/ncurses-5.3/sysdeps/unix/sysv/linux/run_tic.sh
new file mode 100755
index 0000000..aff8cc5
--- /dev/null
+++ b/ncurses-5.3/sysdeps/unix/sysv/linux/run_tic.sh
@@ -0,0 +1,143 @@
+#!/bin/sh
+##############################################################################
+# Copyright (c) 1998 Free Software Foundation, Inc. #
+# #
+# Permission is hereby granted, free of charge, to any person obtaining a #
+# copy of this software and associated documentation files (the "Software"), #
+# to deal in the Software without restriction, including without limitation #
+# the rights to use, copy, modify, merge, publish, distribute, distribute #
+# with modifications, sublicense, and/or sell copies of the Software, and to #
+# permit persons to whom the Software is furnished to do so, subject to the #
+# following conditions: #
+# #
+# The above copyright notice and this permission notice shall be included in #
+# all copies or substantial portions of the Software. #
+# #
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR #
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, #
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL #
+# THE ABOVE COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER #
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING #
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER #
+# DEALINGS IN THE SOFTWARE. #
+# #
+# Except as contained in this notice, the name(s) of the above copyright #
+# holders shall not be used in advertising or otherwise to promote the sale, #
+# use or other dealings in this Software without prior written #
+# authorization. #
+##############################################################################
+#
+# Author: Thomas E. Dickey <dickey@clark.net> 1996
+#
+# $Id$
+# This script is used to install terminfo.src using tic. We use a script
+# because the path checking is too awkward to do in a makefile.
+#
+# Parameters:
+# $1 = the common object directory.
+# $2 = source-directory, i.e., $(srcdir)
+# $3 = destination-directory path, i.e., $(ticdir)
+# $4 = install-prefix, if any
+#
+# Assumes:
+# The leaf directory names (bin, lib, shared, tabset, terminfo)
+#
+echo '** Building terminfo database, please wait...'
+#
+# Parameter parsing is primarily for debugging. The script is designed to
+# be run from the misc/Makefile as
+# make install.data
+
+prefix=/usr
+if test $# != 0 ; then
+ common_objpfx=$1
+ shift
+fi
+
+if test $# != 0 ; then
+ srcdir=$1
+ shift
+else
+ srcdir=.
+fi
+
+if test $# != 0 ; then
+ ticdir=$1
+ shift
+else
+ ticdir=$prefix/share/terminfo
+fi
+
+if test $# != 0 ; then
+ IP=$1
+ shift
+else
+ IP=""
+fi
+
+TERMINFO=$IP$ticdir ; export TERMINFO
+umask 022
+
+# Construct the name of the old (obsolete) pathname, e.g., /usr/lib/terminfo.
+TICDIR=`echo $TERMINFO | sed -e 's/\/share\//\/lib\//'`
+
+# Remove the old terminfo stuff; we don't care if it existed before, and it
+# would generate a lot of confusing error messages if we tried to overwrite it.
+# We explicitly remove its contents rather than the directory itself, in case
+# the directory is actually a symbolic link.
+( rm -fr $TERMINFO/[0-9A-Za-z] 2>/dev/null )
+
+# If we're not installing into /usr/share/, we'll have to adjust the location
+# of the tabset files in terminfo.src (which are in a parallel directory).
+TABSET=`echo $ticdir | sed -e 's/\/terminfo$/\/tabset/'`
+SRC=$srcdir/terminfo.src
+if test "x$TABSET" != "x/usr/share/tabset" ; then
+ echo '** adjusting tabset paths'
+ TMP=${TMPDIR-/tmp}/$$
+ sed -e s:/usr/share/tabset:$TABSET:g $SRC >$TMP
+ trap "rm -f $TMP" 0 1 2 5 15
+ SRC=$TMP
+fi
+
+LD_LIBRARY_PATH=$common_objpfx:$common_objpfx/nss:$common_objpfx/ncurses \
+ $common_objpfx/elf/ld.so \
+ $common_objpfx/ncurses/tic -s $SRC
+if [ $? = 0 ]
+then
+ echo '** built new '$TERMINFO
+else
+ echo '? tic could not build '$TERMINFO
+ exit 1
+fi
+
+# Make a symbolic link to provide compatibility with applications that expect
+# to find terminfo under /usr/lib. That is, we'll _try_ to do that. Not
+# all systems support symbolic links, and those that do provide a variety
+# of options for 'test'.
+if test "$TICDIR" != "$TERMINFO" ; then
+ ( rm -f $TICDIR 2>/dev/null )
+ if ( cd $TICDIR 2>/dev/null )
+ then
+ cd $TICDIR
+ TICDIR=`pwd`
+ if test $TICDIR != $TERMINFO ; then
+ # Well, we tried. Some systems lie to us, so the
+ # installer will have to double-check.
+ echo "Verify if $TICDIR and $TERMINFO are the same."
+ echo "The new terminfo is in $TERMINFO; the other should be a link to it."
+ echo "Otherwise, remove $TICDIR and link it to $TERMINFO."
+ fi
+ else
+ cd $IP$prefix
+ # Construct a symbolic link that only assumes $ticdir has the
+ # same $prefix as the other installed directories.
+ RELATIVE=`echo $ticdir|sed -e 's:^'$prefix'/::'`
+ if test "$RELATIVE" != "$ticdir" ; then
+ RELATIVE=../`echo $ticdir|sed -e 's:^'$prefix'/::' -e 's:^/::'`
+ fi
+ if ( ln -s $RELATIVE $TICDIR )
+ then
+ echo '** linked '$TICDIR' for compatibility'
+ fi
+ fi
+fi