summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbit8
-rw-r--r--bit_bfd18
2 files changed, 24 insertions, 2 deletions
diff --git a/bit b/bit
index 3c16885..f1e0ac0 100755
--- a/bit
+++ b/bit
@@ -1,6 +1,10 @@
#!/bin/sh
#
+# $Id$
+#
+
+#
# Build all add-on packages for the current RTEMS_MAKEFILE_PATH architecture.
#
set -ex
@@ -16,11 +20,11 @@ do
then
makefile="`echo $makefile | sed -e '/-.*/s///'`"
fi
- make -f "$makefile"
+ make -w -f "$makefile"
)
done
for p in $PACKAGES
do
- (cd $p ; make distclean)
+ (cd $p ; make clean distclean || true)
done
diff --git a/bit_bfd b/bit_bfd
new file mode 100644
index 0000000..a6568f6
--- /dev/null
+++ b/bit_bfd
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+#
+# $Id$
+#
+
+#
+# Where to find the binutils source
+#
+BINUTILS_SRC_DIR=~/src/RTEMS/bt/binutils-2.13.1
+set -ex
+
+rm -rf build
+mkdir build
+cd build
+make -w BINUTILS_SRC_DIR="$BINUTILS_SRC_DIR" -f ../RTEMS_Makefiles/Makefile.bfd
+cd ..
+rm -rf build