summaryrefslogtreecommitdiffstats
path: root/ncurses-5.9/man/curs_delch.3x
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-08 15:39:59 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-08 15:39:59 +0000
commit7d428150a7d1d60a127906c29520b4554147ced1 (patch)
tree887b0cfafce298ee955bcc4a591d38af2778b7f8 /ncurses-5.9/man/curs_delch.3x
parent2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-addon-packages-7d428150a7d1d60a127906c29520b4554147ced1.tar.bz2
2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
* bit: Update to ncurses-5.9. * ncurses-5.9/ANNOUNCE, ncurses-5.9/AUTHORS, ncurses-5.9/INSTALL, ncurses-5.9/MANIFEST, ncurses-5.9/Makefile.in, ncurses-5.9/Makefile.os2, ncurses-5.9/NEWS, ncurses-5.9/README, ncurses-5.9/README.MinGW, ncurses-5.9/README.emx, ncurses-5.9/TO-DO, ncurses-5.9/aclocal.m4, ncurses-5.9/announce.html.in, ncurses-5.9/config.guess, ncurses-5.9/config.sub, ncurses-5.9/configure, ncurses-5.9/configure.in, ncurses-5.9/convert_configure.pl, ncurses-5.9/dist.mk, ncurses-5.9/install-sh, ncurses-5.9/mk-0th.awk, ncurses-5.9/mk-1st.awk, ncurses-5.9/mk-2nd.awk, ncurses-5.9/mk-dlls.sh.in, ncurses-5.9/mk-hdr.awk, ncurses-5.9/Ada95/Makefile.in, ncurses-5.9/Ada95/README, ncurses-5.9/Ada95/TODO, ncurses-5.9/Ada95/aclocal.m4, ncurses-5.9/Ada95/configure, ncurses-5.9/Ada95/configure.in, ncurses-5.9/Ada95/make-tar.sh, ncurses-5.9/Ada95/mk-1st.awk, ncurses-5.9/Ada95/doc/Makefile.in, ncurses-5.9/Ada95/gen/Makefile.in, ncurses-5.9/Ada95/gen/adacurses-config.in, ncurses-5.9/Ada95/gen/gen.c, ncurses-5.9/Ada95/gen/html.m4, ncurses-5.9/Ada95/gen/normal.m4, ncurses-5.9/Ada95/gen/table.m4, ncurses-5.9/Ada95/gen/terminal_interface-curses-aux.ads.m4,
Diffstat (limited to 'ncurses-5.9/man/curs_delch.3x')
-rw-r--r--ncurses-5.9/man/curs_delch.3x68
1 files changed, 68 insertions, 0 deletions
diff --git a/ncurses-5.9/man/curs_delch.3x b/ncurses-5.9/man/curs_delch.3x
new file mode 100644
index 0000000..08af9af
--- /dev/null
+++ b/ncurses-5.9/man/curs_delch.3x
@@ -0,0 +1,68 @@
+.\"***************************************************************************
+.\" Copyright (c) 1998-2006,2010 Free Software Foundation, Inc. *
+.\" *
+.\" Permission is hereby granted, free of charge, to any person obtaining a *
+.\" copy of this software and associated documentation files (the *
+.\" "Software"), to deal in the Software without restriction, including *
+.\" without limitation the rights to use, copy, modify, merge, publish, *
+.\" distribute, distribute with modifications, sublicense, and/or sell *
+.\" copies of the Software, and to permit persons to whom the Software is *
+.\" furnished to do so, subject to the following conditions: *
+.\" *
+.\" The above copyright notice and this permission notice shall be included *
+.\" in all copies or substantial portions of the Software. *
+.\" *
+.\" THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS *
+.\" OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF *
+.\" MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. *
+.\" IN NO EVENT SHALL THE ABOVE COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, *
+.\" DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR *
+.\" OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR *
+.\" THE USE OR OTHER DEALINGS IN THE SOFTWARE. *
+.\" *
+.\" Except as contained in this notice, the name(s) of the above copyright *
+.\" holders shall not be used in advertising or otherwise to promote the *
+.\" sale, use or other dealings in this Software without prior written *
+.\" authorization. *
+.\"***************************************************************************
+.\"
+.\" $Id$
+.TH curs_delch 3X ""
+.SH NAME
+\fBdelch\fR,
+\fBwdelch\fR,
+\fBmvdelch\fR,
+\fBmvwdelch\fR \- delete character under the cursor in a \fBcurses\fR window
+.SH SYNOPSIS
+\fB#include <curses.h>\fR
+.sp
+\fBint delch(void);\fR
+.br
+\fBint wdelch(WINDOW *win);\fR
+.br
+\fBint mvdelch(int y, int x);\fR
+.br
+\fBint mvwdelch(WINDOW *win, int y, int x);\fR
+.br
+.SH DESCRIPTION
+These routines delete the character under the cursor; all characters to the
+right of the cursor on the same line are moved to the left one position and the
+last character on the line is filled with a blank. The cursor position does
+not change (after moving to \fIy\fR, \fIx\fR, if specified). (This does not
+imply use of the hardware delete character feature.)
+.SH RETURN VALUE
+All routines return the integer \fBERR\fR upon failure and an \fBOK\fR (SVr4
+specifies only "an integer value other than \fBERR\fR") upon successful
+completion.
+.PP
+Functions with a "mv" prefix first perform a cursor movement using
+\fBwmove\fP, and return an error if the position is outside the window,
+or if the window pointer is null.
+.SH NOTES
+Note that \fBdelch\fR, \fBmvdelch\fR, and \fBmvwdelch\fR may be macros.
+.SH PORTABILITY
+These functions are described in the XSI Curses standard, Issue 4. The
+standard specifies that they return \fBERR\fR on failure, but specifies no
+error conditions.
+.SH SEE ALSO
+\fBcurses\fR(3X)