summaryrefslogtreecommitdiffstats
path: root/bit
diff options
context:
space:
mode:
authorEric Norum <WENorum@lbl.gov>2003-02-05 21:00:12 +0000
committerEric Norum <WENorum@lbl.gov>2003-02-05 21:00:12 +0000
commitd3c2c6f1b984070644d68c989985e0b578a7396e (patch)
tree6a0b25970aab3e4b00948c1e60dee42afb36f8d8 /bit
parent2003-01-28 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-addon-packages-d3c2c6f1b984070644d68c989985e0b578a7396e.tar.bz2
Make sure that script terminates if a make fails.
Diffstat (limited to 'bit')
-rwxr-xr-xbit17
1 files changed, 8 insertions, 9 deletions
diff --git a/bit b/bit
index 8dc20ab..4be5df0 100755
--- a/bit
+++ b/bit
@@ -13,15 +13,14 @@ PACKAGES="avl-1.4.0 ncurses-5.3 readline-4.3 libtecla-1.4.1"
for p in $PACKAGES
do
- (
- cd $p
- makefile="../RTEMS_Makefiles/Makefile.$p"
- if [ \! -r "$makefile" ]
- then
- makefile="`echo $makefile | sed -e '/-.*/s///'`"
- fi
- make -w -f "$makefile"
- )
+ cd $p
+ makefile="../RTEMS_Makefiles/Makefile.$p"
+ if [ \! -r "$makefile" ]
+ then
+ makefile="`echo $makefile | sed -e '/-.*/s///'`"
+ fi
+ make -w -f "$makefile"
+ cd ..
done
for p in $PACKAGES